[How To] - Mikrotik Router with NUC, failed to configure the core for remote access

I am trying to configure ARC for remote access and am not having much luck:

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“xx.xx.xx.xxx”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}
}

the core is a NUC i7, the router is a Mikrotik wired router running RouterOS. There is an unmanaged tplink switch between the core and the router, with the router plugged directly into the cable modem.

How do I configure the mikrotik RouterOS to play friendly with ARC?

By the way, I have also tried enabling Mikrotik’s UPnP feature, but that did NOT work in my case. I didn’t troubleshoot this approach in too much depth, as I’m weary about UPnP to begin with and think that it typically isn’t worth the vulnerability risks.

1 Like

I see two options:

#1 VPN into your home network and not worry about the Roon Core being able to communicate with the internet

#2 Manually configure the firewall and NAT to allow communication with your Roon Server (Core). For this you would:

/ip firewall filter
add action=accept chain=forward comment=“Accept incoming ROON ARC” dst-port=50055 log-prefix=“ROON ARC” protocol=tcp

/ip firewall nat
add action=dst-nat chain=dstnat comment=“Access to ROON Core from Internet” dst-port=50055 protocol=tcp to-addresses=XXX.XXX.XXX.XXX to-ports=50055

Finally, set your Roon Core to port 50055 and you should be all set.

Port 50055 is my example, but you can use any unused port in the range Roon Core supports for ARC.

Hope this helps. I just did this for my setup at home.

2 Likes

Brilliant, #2 worked! many thanks for your help!!

2 Likes

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.