How to operate HQPlayer from Roon

Hello, I’ve followed this page but can’t seem to get HQPlayer going. https://help.roonlabs.com/portal/en/kb/articles/hqplayer#Setting_Up_Roon_And_HQPlayer
I must be missing something? Will appreciate some help to point me in the right direction, thanks.

My setup:
(1) Roon Core v1.8= Roon Rock on a dedicated NUC i5-7260U (Linux)
(2) Roon Remote v1.8 = on i9-12900 DDR5 32Gb (Win11)
(3) Bridge = opticalRendu
(4) DAC = Holo May

My settings in Roon as shown below. I’ve “added HQPlayer” and selected HQPlayer in Roon’s audio zone. But I can’t play anything… the Play button is grayed out. Besides, if I select HQPlayer as the audio zone, where does it play to?

Am I supposed to Enable the ASIO drivers or those “HDA Intel” stuff?

I’ve check out these other pages as well:

…and various other forum pages.

How is your HQPlayer setup? Meaning do you have the Desktop or Network versions installed? Do you have HQPlayer Desktop installed on your computer with Roon Remote installed? If so when you added HQPlayer to Roon through the setup menu did you add it by Ip address or did you add it as localhost? You will want to add it as the ip address of the Roon Remote machine.

Hopefully this can help lead you in the right direction or at least give some more details. Hopefully you can get it working!

Thanks @TheRiz I’m using HQPlayer 4 Desktop installed in (2), i.e. the same machine as Roon Remote (but not Roon Core). I’ve added HQP to Roon and enabled it. I also added HQP using its IP address (since it is installed in a different place as Roon Core).
Actually I’m not clear if I’ve set Roon or HQP incorrectly!

If you open HQPlayer on your computer and go to settings, you should have a similar setup for the top half.

Are you trying to run DSD or PCM from HQPlayer?

You can also try pinging your Rock just to make sure it’s not a network issue.

Yes indeed. I followed your setting. This is really strange. ROck is okay… when I play Roon directly (without HQP) it works well, i.e. Rock/Remote and signal chain works well. I must have a wrong HQP setting then.

For now, I’m trying to run PCM from HQP.

Question, can you run HQPlayer by itself successfully without using Roon?

It also may be a processing power issue while running Roon Remote with HQPlayer? I would try getting HQPlayer to work without up sampling first and then go from there.

No I can’t, hence suspecting now that it is my HQP (not Roon) setting.
Yes, I’ve read HQP can be a CPU killer, that’s why I built an i9-12900 with 32Gb DDR5… it shouldn’t be a processing issue because I can’t even get it to play.

@koay_family Hopefully this finds you well. If you haven’t been able to figure this issue out yet, maybe this will help. I had an issue with playing when setting up the embedded version. It ended up being my firewall that was the culprit. Figure I would let you know; hope you figured your issue out!

Thank you @TheRiz The firewall has indeed stumped me many a times.

This time though it was my own problem… I bought the opticalRendu Lite ($500 cheaper) but which works for Roon only, since I use Roon only. The oR Lite worked beautifully… until I tried using HQP. The HQP comes after Roon in the signal chain, i.e. oR Lite doesn’t accept it.

Here’s the good news, thanks to Andrew Gillis of SGC who agreed to swap the oR Lite for the regular oR. Eagerly awaiting the arrival of the oR to play with HQP.

2 Likes

Have you selected Enable Network Control in HQ Player ? It is the rightmost icon in the top icon row of the Desktop client.

Hi, yes I did.

I’ve re-setup my Roon, bridge and HQP. HQP can now play directly but my Roon can’t detect the HQP… “Roon couldn’t connect to HQPlayer”.

I’ve read several other posts on the same problem, but unfortunately the solutions don’t work.

Here’s my setup:

  • HQP Network already enabled
  • HQP Output Device Setting = NetworkAudioAdapter
  • HQP Input Device Setting = ASIO

Roon Settings:

  • Setup: Added HQPlayer
  • Audio: Enabled HQPlayer
  • Audio Zone: Selected HQPlayer

Sonicorbiter (I use opticalRendu & microRendu)

  • Installed HQPlayer app

Signal Path:
Roon ROCK on i5 NUC >> HQPlayer on i9-12900 32Gb DDR5 >> opticalRendu (and separately another microRendu)

What else should I do? Thanks!

If you’re using opticalRendu & microRendu (NAA’s), shouldn’t your device output indicate that?

Do you have the latest version of HQPlayer installed ?

You’re trying to run HQP Desktop on a PC, right?
But if you have a sonicTransporter, you also can run HQP from there, right? Have you tried to do that?

I have two HQP versions, one on my sonicTransporter i9 and a desktop version on a Mac Mini. When I run it on the Mac Mini, I use a direct USB connection to a streamer/DAC (and the ultraRendu is unused). The Settings pane looks like this:

Can you make it work with a direct USB connection (and no NAA/Rendu in the loop)?

Thanks for all your tips.
@Swisstrips Yes, my HQP settings look like that. I can play from HQP directly, but can’t do so from Roon. Roon says, “…Roon couldn’t connect to HQPlayer”.

@Outlaw I use the (latest) trial version of HQP now. Wanted to ensure it works before I buy. I read from another user that it can be used after we click OK to acknowledge that the trial version can only be used for 30 minutes.

@Tom_K Yes, I’m running HQP for Desktop on a PC (should be no issue with processing power since this is an i9-12900). My opticalRendu is connected via a switch, i.e. not connected directly to the PC. This shouldn’t be a problem since I can play music directly from HQP to opticalRendu.
I just can’t use Roon. Must be a Setting problem. Roon needs to connect to HQP, but it is now saying, “…Roon couldn’t connect to HQPlayer”.

To be clear:

  • I can play music from Roon directly to oR and mR
  • I can play music from HQP directly to oR and mR
  • But I can play music using Roon to HQP to oR (or mR)

Am I missing something from the Roon (or HQP) Settings?

Sorry I meant “But I can’t play music using Roon to HQP to oR (or mR)”

Hi folks, I solved it after fiddling around Roon Settings. Felt like a blind monkey with a typewriter… finally typed one legible word “okay”! (I still have other issues but will address this elsewhere).
Thanks for your earlier tips! Helped me eliminate some questions.

One challenge with using HQP is that there are many different users with different setups. I imagine it is difficult for Jussi/Signalyst to have a User’s Manual that solves everything.

For the benefit of others, here’s my inductive conclusion of the solution for me…

If you’ve have Roon Rock installed in a different machine (eg in a NUC) from where the HQP is installed (eg in a PC desktop or MacMini)…

Sonicorbiter Settings (if you use Sonore products) via sonicorbiter.com

  • Network Player - Manage
  • click on Apps - HQPlayer NAA
  • the next page will show HQPlayer’s Network Audio Daemon (NAA). Click on Restart NAA HQPlayer

HQP 4 Desktop Settings:

  • File-Settings - Output Device Setting - Backend - NetworkAudioAdapter
  • File-Settings - Output Device Setting - Device - (Select your device from the drop down menu)
  • also separately click on “Network” (button on top-right on the menu bar)

Roon Settings:

  • Setup - HQPlayer - Add HQPlayer … do NOT type “localhost” if your HQP is not installed in the same machine as Roon Rock … instead, type in the IP address (or name) of your PC where your HQPlayer had been installed

  • Audio Settings - select HQPlayer (or whatever you’ve named it)

I think that’s about it. Enjoy.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.