[How To] - Setup manual port forwarding, otherwise ARC Connection Fail

I need help with ‘ROON ARC’ connection.
Connection related messages are as follows.
What should I check?


“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},

“external_ip”: {“actual_external_ip”:“xxxxxxx”,“router_external_ip”:null},

“natpmp_autoconfig”: {“status”:“NotFound”},

“upnp_autoconfig”: {“server_ip”:“XXXXXX”,“found_upnp”:true,“error”:"<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/" s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">500Invalid Port Command</s:Fault></s:Body></s:Envelope>"}


Having the same error here and it comes from the fact that my Internet provider (Vodafone) uses shard IP-addresses and not dedicated one.
There seams to be no real solution available. My provider would only offer dedicated public IP-addresses in business like service offerings.

I have the same problem

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“82.xxx.xxx.x”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“doaction request return statuscode: UnknownError”}

I use ASUS RT-AC2900 as router.


Does the Vodafone router allow port forwarding at all?

same here with the following:

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“xxxx”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">501ActionFailed</s:Fault></s:Body></s:Envelope>”}

I solved the problem.

  1. Add port in OS or management service.
  2. Allow the port in the firewall.
  3. Add the port in Port Forwarding of the router.
  4. test ping and the port to see if the port is normally open. (ex. Run tcping with cmd to check)
    ref. tcping.exe - ping over a tcp connection
  5. The above port is TCP, but if that doesn’t work, try adding UDP. I opened the port by adding UDP in the firewall.

Please find the settings related to the port in the OS or windows of the NAS and add them manually.
Roon ARC is a task that requires a lot of checking. :slight_smile:

Sounds like a piece of cake. Only wish I understood it.

1 Like


  1. I fixed the issue by allowing UPnP on the firewall config settings of my ISP’s modem.
  2. I also changed the setting of my Netgear Orbi 6 router/wifi from router mode to access point mode (AP mode)); this also stopped this Orbi router from acting as a DHCP server and assigning a IP address on my network. (The modem/router provided by my ISP already assigns an IP address via its DHCP server.
  3. Note: No need to configure port forwarding, in my case.
  4. Note: Not sure if step 2 is necessary.

Old message:

Could someone of the Roon support elaborate/verify the above, please?

I have the same error message when trying to connect my Roon Nucleus.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.