How to shuffle an album's songs?

So, I’m listening to Hamilton in Roon on my Mac’s desktop. I’d like to shuffle the songs on the record. I wen to the play now button and clicked the arrow, and then shuffle. It takes me to the first song, and then they play in sequence. I must be doing something wrong.

Can anyone help? I’ve listened to the first 7 songs so much, I need to mix it up!!!

Thanks kids!

Shuffle isn’t one of the default actions for albums, but you can enable it in Settings > Play Actions > Albums.

Maybe I wasn’t clear. Shuffle enabled. It works on other records. But for some reason, the “Hamilton” soundtrack won’t do it. This makes no sense.

Can you skip between tracks?

yes, they go in sequence.

That’s weird isn’t it? So even with shuffle for the zone set to yes, Hamilton says no…

Sounds like the individual songs aren’t really individual tracks.

Screen print of queue?

I think the issue is that the Hamilton album is considered a single Work with multiple Parts. Perhaps Shuffle only operates at the Work level?

Yeah, that’s where I was headed.

A screen print will clear that up.

Yeah I think that is it. Boo. Any workaround?

Can you put the parts into a Playlist, and then shuffle the Playlist?

Good idea, but no joy. Each song was

represented but shuffle did nothing.

The fact that is references 46 parts means parts not tracks.

Can you play just one song from the middle somewhere? Probably not.

There is software that will split out these parts into tracks.

Depends on how serious you are about this.

I can, actually, play any song from the middle. If you have any recco about software that would be great!

For yuks, let’s try something else first.

Since you can select a single part to play, what I’m suggesting might work.

One at a time, rather than en masse, add a single part to a playlist. To be on the safe side, don’t add the parts sequentially.

When you get all the parts in your playlist, then play it and see if the parts stay out of order, i.e. but in the order that you added them…

If that works then try shuffling the playlist.

Have you tried disabling multi-part composition? Then it will shuffle.

three dots -> edit -> edit album -> scroll to the bottom

You can also switch off multi-part grouping globally if you have no use for it, but I cannot remember where. I mostly have multi-part grouping switched on as that is how Classical music works. If you are playing a piece you want to hear it in the right order.

But there are scenarios where it would be better if roon would suspend multi-part grouping. For example shuffle/radio where one 3 hour opera in its entirety followed by another one isn’t really a shuffle or radio experience. There are several feature requests.

2 Likes

I just tried this and it worked for me. I checked the box then added it to the queue and then shuffled the queue.
Before:


After with shuffle:

1 Like

Many many thanks!!! You guys rule

1 Like

I see and have the same issue you described, where you play an album but don’t finish it then later on you decide to play it again and end up listening to the same subset of songs because it always starts at the beginning, so besides a shuffled solution, here are 2 ideas:

  1. when you want to play said album, instead of clicking Play or Play Shuffled, just scroll down to where you last left off and select the track and Play From Here.

  2. Browse the Queue, find where you last left off and again select Play From Here.

I’m an Album person and in some cases shuffle play is not what I want, isn’t Hamilton a Play, so doesn’t shuffling mess up the order of the program, thus the order of play can be maintained using the Play From Here options.