HQ Player Volume Control


#1

I added my HQ Player to roon and I can switch the audio to HQ Player without issue. However, since my DAC does not have physical dial to control the output volume, so I expect the volume control can be done in roon. I choose “Device Volume” for the “HQPlayer” device, when I click on the speacker icon, it always shows “Volume control is fixed”. And on HQ Player side, I have toggled the “allow control from network” icon on the toolbar, what should I do next?


#2

Copied from the User Guide:

Volume Control Mode

There are a number of options here, and they vary by platform. For more information on platform-specific options, see the platform-specific audio pages, linked at the bottom of this page.

There are a few options that pertain to all platforms. Those, we’ll describe here:


Use Device Controls causes Roon to pass volume commands on to your device via the device’s driver. Exactly what happens next varies from device to device. If your device advertises a high-quality volume control over USB, it’s likely that this is the setting that you want.

DSP Volume uses Roon’s built-in 64bit dithered volume processing. This is a high quality option, but should not be your first choice for hardware that provides volume control natively.

Fixed Volume disables volume control from within Roon, sending a fixed-level output signal to the audio device. Use this setting if you plan to control volume elsewhere–for instance, on your pre-amplifier or AV receiver.

As I don’t know HQPlayer, is DSP Volume not available? If so, I assume that you have to set the volume in HQPlayer.


(Steven Edwards) #3

Make sure DirectSDM is not checked and you will have DSD volume control in Roon


#4

Yes, you are right. This solved the issue. Thanks a lot, really appreciate it.