HQP 3.13 beta...does DSD->PCM work now in Roon?

Just wondering if anyone who has installed the 3.13beta tell me if DSD->PCM works now with Roon? (before I download and install, I thought I’d ask here).

I may be in the minority but I think I prefer PCM playback over DSD. I mainly listen to various genres of rock and metal and sometimes find that DSD takes out some of the punch and/or detail, muddies it up over the original PCM so to speak, but I do like how DSD reduces the amount of digital harshness that you may sometimes get… again could just be my DAC and it’s preference for playback.

Yes DSD->PCM works for me HQP 3.13.0b3, Roon 99, (on MacBookPro), few others have reported the same. What DAC are you using?

Great, thanks @KMan. My DAC is a Unison Research CD Due.

Anyone on a Mac having an issue with going back and forth between PCM and DSD?

It seems to completely not let my DAC play DSD anymore and plays static. Not just Roon/HQP but Audirvana+ and JRiver won’t play DSD files after adjusting settings between PCM / DSD in HQP… My guess is it’s done something to CoreAudio but not sure what.

After an hour of playing around with shutting down/unplugging, swapping USB, checking system sound prefs, I finally got DSD back working, but I gotta believe it’s an HQP and CoreAudio issue that started the problem?

I have always had problems going between DSD (DoP) and PCM (MBP -> NAA (Audiolinux)), it is less so after 3.13.0b3. When I want to switch between DSD and PCM, I am extra careful.

  1. I disconnect (volume, click link), then use Command + T.
  2. Wait for HQP to be responsive (the drop-downs will be enabled),
  3. Then clear the playlist on HQP (sometimes you may have to press stop button then clear).
  4. To be extra safe you can restart HQP.
  5. Switch between DSD and PCM

If I just switch between DSD and PCM in a hurry, more ofthen than not I get static that would require restarting my NAA. I don’t think it is specific to Coreaudio, maybe the driver gets confused between DoP and PCM rates.

Kinda glad to see it’s not just my system and hopefully this gets worked out.

Same 3.13b3 works great.