HQPlayer Embedded Discussion [2021-2022]

Hi @jussi_laako

I previously had ROC/HIP repository successfully installed to have hqplayerd_4.22.3-67_amd64.deb working. That was all working great.

Today I updated to hqplayerd_4.23.0-69_amd64.deb on i9-9900K Ubuntu Focal and got the below messages.

Is this normal/expected? Can I ignore or should I do something?

I even ran sudo apt install -f but maybe my sequence wasn’t right because it ended up removing hqplayerd

1 Like

Please try with the new 4.23.1 package. AMD keeps reshuffling their repository and packaging so it is a bit shooting on a moving target…

1 Like

Thanks Jussi, all good now

As a general request, is the manual, or e.g. the table describing filters possible to make as a standalone download from webpage? Now I had to download, install and retrieve the manual, and finally uninstall the desktop version. Kinda long way home … Perhaps already there, but have not been able to locate it?
All the best <3

That is included in HQPlayer Embedded help. You don’t need HQPlayer Desktop or it’s manual for that. HQPlayer Desktop manual applies to that product. Embedded has it’s own documentation.

Hi @jussi_laako

Since HQP OS 4.24.2, UAC2 input with UpBoard Gateway has been broken for me, when changing sample rates.

Broken With both ALSA backend (RME ADI-2) and naa backen ( naa image on RPi4 connected to RME ADI-2)

Can you reproduce this also?

UAC2 input works properly with hqplayer-embedded-4.23.0-x64


Funny, I have been struggling to find a help section you refered to on the Signalyst web pag. Just a day ago I found a link way up in the right corner of the hqp embedded web UI. On this pic below one get the idea how this displays at home on my 24 inch high res screen.
I have honestly not even seen this link. Would it be possible to relocate the link to the others bottom left? It makes more sense to place it together with the rest, is it not? Now, it no longer matters to me, but for other newbies, visually impaired and perhaps a bit stupid (i.e. myself).

Just a suggestion :slight_smile:

Hi @jussi_laako are you seeing this error on Ubuntu , with sudo apt-get -y update ?

I ran it , before installing latest HQPe update

No, I have not seen that error. Typically it happens if repository is in the middle of being updated, or mirror has fallen partially out of sync with a master. It should get corrected over time.

1 Like

Hi @jussi_laako

I know HQP OS supports auto sample rate switching via RME ADI-2 Pro input (using their included breakout cable).

Should RME Babyface Pro FS also work, which features TOSlink input + USB output.

Or something you never tried?

I don’t have it and thus the driver doesn’t have the needed functionality, so no it won’t work at the moment. I don’t know if the firmware has required functionality. ADI-2 family does.

1 Like

So non-Pro ADI-2 works also as auto sample rate switching with HQP OS? Have you tested?

Or only Pro model works?

ADI-FS DAC (non-Pro) has TOSlink and digital coax inputs which can be routed to USB output

1 Like

No, I have not tested, but yes it should work since it is almost the same as Pro, just with ADC and AES/EBU dropped out. And the driver I created has support for it.

Yes, I know.

Pro just makes more sense for input tasks, since it can also deal with analog inputs and has 3 digital ins and outs.

1 Like

Noted but some ADI-2 can be found for really cheap now (on the used market). Doesn’t need to be FS model for this task. Especially if only TOSLink or digital coax input is enough.

The big upside is auto sample rate switching.

UAC2 input is not working at all for me with UPBoard Gateway. It used to. Something happened with releases that caused sample rate switching to crash.

I’m just re-jigging my setup to test with my ADI-2 TOSlink input + miniDSP USBStreamer’s TOSlink output.

Which input on HQP OS is correct?

You need to check the device id with “arecord -l” and then manually edit and enable it in /etc/hqplayer/hqplayerd.xml configuration file. It cannot be pre-configured, because for a reason ADI-2 encodes serial number in the device id (in order to properly support multiple ADI-2’s on a single system).

1 Like

Can you show me the formatting of your line that you entered in hqplayerd.xml configuration file

So I enter the same , just changing my device ID

Only one line for one input sample rate is required?

Example is in the configuration file already. Note that the device id is there several times, so pay attention to change it on all of them.

Yes… It is just for “auto” rate. One line per input type.

1 Like

Got it working with HQPe on Ubuntu Server (Focal) using your custom kernel. Will try HQP OS next.

When I change sample rate in Audio MIDI to PCM44.1k, ADI-2 screen sample rate changes (nice) but this doesn’t change automatically:


Can you see anything glaringly wrong with the new RME inputs I added?

Yes, it is lacking all the needed things, plus has the unnecessary extra of various sample rates listed. If you are on Ubuntu Server, take a look at the /usr/share/doc/hqplayerd/hqplayerd.xml-rme.gz example file.

On HQPlayer OS you can find /etc/hqplayer/hqplayerd.xml-rme

1 Like