HQplayer Lost NAA

Two days ago I set up a MicroRendu. It was working fine but today HQP will not find the microRendu NAA address.

MicroRenu works fine in Roon mode without HQPlayer. I have rebooted the router, the MicroRendu and the Roon host. Network control of HQPlayer is turned on.

Any ideas what went wrong overnight? Thanks!

Dumb question…you mentioned rebooting everything but HQP. I assume you have tried this too?

When the DAC is switched off or an input other than USB selected, then the USB input ceases to exist. This seems to cause HQP/NAA more problems than Roon Ready devices. The best work around is to close down HQP before turning off the DAC or switching inputs and turn it on again only after re-establishing the DAC input.

Check whether HQP is seeing the mR in the Network naming Tool. If so then it should appear as available in the drop down menu in Settings. If it’s not there, check that the DAC is on with USB selected. You may need to restart HQP, or the computer on which it is running. Try switching the mR back and forth from Roon Ready to NAA. If none of that fixes it, try reinstalling HQP.

I have restarted HQPlayer numerous times as well as the host NUC. The network address is not visible in HQPlayer at all.

How do I uninstall HQPlayer? It is not in the program’s list. Is it under soun devices?

BTW I did install the latest microRendu software early today. Surely that is not the problem.

Windows search found the uninstall program so I am rebooting the NUC and will reinstall HQP.

Instead of uninstalling HQP perhaps you can delete the xml settings file which will allow HQP to essentially start over.

Did the reinstall and same thing.

Let’s drop a flag for @jussi_laako and see if he can suggest anything.

I found the problem!! I read on Computer Audiophile’s HQPlayer forum that when HQP can’t find the NAA then the problem is definitely network related (makes sense but everything else on the NUC worked fine). I opened the network settings on the NUC and the Ethernet connection looked really strange. So, I moved Roon and HQPlayer to a desktop and all is working.

So, gotta find the problem on the NUC. An update to Norton’s was installed yesterday and it could be that the firewall somehow got set to block HQP.

Anyway, thanks for all the help, my friends:slight_smile:

I reset the NUC BIOS and all appears to be well now. It is finding the microRendu in HQP. Whew, what an ordeal!

All the problems appeared again this afternoon. Isolated it to a bad network card in the NUC. WiFi seems to work fine so I disabled the wired Ethernet in network settings and am only using WiFi. Oh well!!

Are you upsampling to DSD? Curious if wifi can handle it. Also, does the NUC have wifi AC?

Had company this afternoon so not much time to experiment. Yes I do up to DSD and the WiFi question is certainly valid. I am going to try a USB 3.0 to Ethernet adapter. If that doesn’t work I have an i7 desktop that I can move everything to. Just prefer the lower power consumption of the NUC for something that will be on all the time.

I don’t think this NUC has AC.

NUC network card failure seems to be fairly common based on a quick Google search and of course it cannot be replaced without swapping motherboard.


Good call on the USB to ethernet adapter. I use one as well on my server to get another network port. Works very well for me.

It happens to me occasionally. Definitely some kind of network issue. Basically I reboot everything and then it works again.

I moved Roon and HQPlayer over to a Dell i7 desktop and everything is running perfectly. So, the problem is definitely with the NUC and not either software. I am going to dedicate the NUC to other service and put Roon and HQP on a dedicated i7 desktop with a 960GB for the OS, Roon and HQP. Storage will either still be my NAS or a regular hard drive as the D drive in the desktop.

BTW, I did try upscaling to DSD 128 on the NUC with WiFi and had a lot of stuttering, so the comment about WiFi not being enough was true, at least for me.

Thanks, everyone for your suggestions on fixing this.

1 Like

I am still confused as to what needs to be turned on in what sequence. I end up trying different things until I get the link from the Roon host PC to the microRendu working. Thankfully I have access to the host PC using SplashTop on my iPad. Any help would be appreciated since I have just ordered a SonicOrbiter for another room.

The microRendu is on all the time; so is the host PC. I leave Roon and HQPlayer running on the host PC at all times. When I turn on the DAC I have to restart HQPlayer and Roon at least twice to get the NAA link to work.

Please tell me what should be turned on when, step by step. Also, is there a way to assign a static IP to the microRendu? I did not see a way to do that from the microRendu setup web page.

I have Roon and HQPlayer running flawlessly on a dedicated desktop i7. I did get the NUC to work with a USB 3.0 to Ethernet adapter but the responsiveness using the desktop is faster so I probably will leave it that way. The desktop has a 960GB SSD that the software and OS are on plus a 3TB 5400 “D” drive that has all the music on it. However, I have not noticed much speed difference between the internal drive and my Synology NAS. The NAS is set to auto backup to another NAS so I really prefer that solution.

Thanks again for any help with the NAA questions.

Best course I have found is not to have HQP running when making any change to my DAC. So when starting up, turn on the DAC before starting HQP. When changing inputs on the DAC or shutting down, stop HQP first.

See discussion on CA here about fixing a static IP. Mapping the MAC address in the router is what some have done.

Thanks, Andrew. I set a static IP using the info in the link in your reply. Kinda odd since I am used to assigning static IP from the device itself. Also thanks for the info about not starting HQP until the DAC is on. I will try that this afternoon.