HQPlayer, Rasberry Pi with RopieeeXL?

Currently, I’m using Roon with a Pi and RopieeeXL. To try HQplayer do I need to remove Ropieee and install something else? Or is it possible to work in this current setup?

Thanks.

RoPieeeXL includes the HQPlayer NAA endpoint software as an option. However, you need a PC (and likely a rather beefy one, at that, depending on what options you enable) to run HQPlayer itself on. So your chain would be Roon -> HQPlayer -> RoPieeeXL NAA.

1 Like

Thanks. I tried setting it up based on the instructions provided in the Roon knowledgebase but it wouldn’t work. The HQPlayer was a zone but wouldn’t play.

Is there something special I need to do?

EDIT: Ah! The setting in RopieeeXL. Trying again.

I am not a HQPlayer user, myself, so can’t provide any specific guidance. Hopefully one of the moderators will move this post to the HQPlayer section, where the author of HQPlayer is more likely to see it.

I moved this to Audio Products - HQ Player.

1 Like

Thanks. Got it working. @cwichura tipped me off to the Ropieee setting.

When using HQplayer I have to turn the volume way up. Is that normal?

What settings do you have on the HQPlayer volume control ?

As you can see under the volume control on the right it’s currently set to -20dB.

You need some headroom depending on what you are doing. I can’t tell what you are upsampling to, might not be upsampling at all. Try-3dB and see if the limit indicator increments, if so decrease volume 1dB at a time until it stops.

You can set the min/max limits of the volume knob in Settings.

Have a read of the HQPlayer manual, you’ll find the latest version in the HQPlayer directory. It’s not like most audio manuals, has a very high signal to noise ratio.

1 Like

Much better at -3dB.