HQPlayer skipping on headless NUC, need help/advice

Hi all

I’m using the latest Roon/HQplayer versions on a brand new NUC 12 with a 12th Gen Core i9/64GB RAM. The NUC is headless and I use my laptop to remote in using Windows’ Remote Desktop Connection. With all that horsepower the NUC runs HQPlayer flawlessly with my preferred filters, as expected.

However when I want to just listen to music and end the remote session (either by shutting down my laptop or by just ending the remote session), after a couple of minutes HQplayer starts skipping. If I re-establish my remote connection, skipping goes away.

So my guess is ending the remote session triggers some sort of aggressive power management although I can’t for the life for me figure out which one. I’ve set my NUC to Performance mode, and have looked at Windows’ power settings and i can’t find anything amiss.

The rest of my setup: NUC → Ethernet → Ultrarendu NAA → Holo Spring 3 → WA33.

If anyone has any idea how to troubleshoot this, I’d be really grateful, thanks.

On my headless Windows 10/11 servers I have HDMI 1080p EDID spoofer dongle attached, so Windows thinks there’s a display. And then I’m running TightVNC server on Windows. At least when used this way, Windows doesn’t have any idea whether there is remote session or not. This has been working great.

I abandoned Windows Remote Desktop myself because it was negatively affecting Windows behavior.

This is very helpful. Will try both the dummy dongle and Tightvnc and report back.