HRT Music Streamer II muting

Just connected my HRT Music Streamer II dac to Roon Rock installed on my NUC7I3. The dac is sending a mute signal over USB and so I get no sound output when a track is played and I can’t work out how to un-mute it in the Rock software. Using the dac on a Windows pc the same problem occurs, but Windows sound settings lets me un-mute the dac. Is there a way to do likewise in ROON Rock?

I have the same problem. Is there anyone out there with a solution?

I think the mute behaviour was fixed with a firmware update. Check highresolutiontechnologies.com
Today I only have the (discontinued) Headstreamer. Worked fine when I last used it with a microRendu which is also Linux.

1 Like

Many thanks ogs. Got the latest firmware from high resolution technologies as you suggested and updated my Music Streamer II and the muting issue is now resolved. I hadn’t realised that the device could be updated.
Thanks again,
James

@James_Lyle , I too have an HRT Music Streamer that has been sitting around bricked because it is stuck on mute. I was almost ready to discard it and then saw your note here. I cannot locate the firmware upgrade you reference on the HRT site nor instructions on how to install it. Could you kindly share? We can handle via PM if appropriate. Thanks. JCR

I recently tried to re-download the firmware update from HRT but found it was no longer there. I know I have a copy in my pc backups somewhere (downloaded it 3 years ago). I will dig it out tomorrow and let you know when I have it so that we can arrange to transfer it to you. I use my HRT music streamer 2 almost every day as it sounds so good.
James

Great, thank you. JCR

Sorry JCR, I have found the software to update the streamer, but I’m having problems getting it to work. This may be because I already have the latest update installed or because something has changed since I last did the update 3 years ago
The updater (Upstream) requires a binary file (the new update image) which I don’t have and don’t recall having. It may have been obtained from the internet during the updating process or automatically from the firmware zip file, but the zip file is very small and I can’t see how updates for all HRT’s products could be in the file.

The process for updating the firmware that I followed is described below:
The files were downloaded from here: High Resolution Technologies – Support and downloads
I downloaded the ‘Upstream’ executable (this ‘burns’ the update to the streamer’s EEPROM) and the firmware zip file at the bottom of the page. [I have done this, but can’t unarchive the zip].
I then connected my streamer to my PC via usb, then ran the Upstream executable. I clicked LOAD and this requested a .bin file (the image). I don’t recall any problems at this stage as the whole process was straightforward at the time. I then clicked WRITE and my streamer updated.

Incidentally you can also download the executable USBView and it’s instructions. This will enable you to see which version of the firmware you have loaded on your streamer.

I’m sorry I can’t be more help - the whole process took me only a couple of minutes 3 years ago and I don’t recall any difficulties and have never had to repeat the process. I have sent an email to HRT requesting a copy of the latest firmware update file (.bin), but as they are in LA a response may take a while. I’ll let you know if they respond. If they send the image, the process to update will be very quick.
Regards
James

@James_Lyle , this caught me eye since I have one also, connected to an RPi (I don’t see many posts about the MusicStreamer II). Works great. Are you trying to use it plugged directly in to your NUC w/USB?

Mine was working fine connected to an rpi as a Roon endpoint until it suddenly went into Mute mode. @James_Lyle , I hope you get a response back from HRT. I actually sent them a note over a month ago and never got a response. JCR

Mine is connected to a RPi and since the firmware update it has never gone into mute. When I first got it (without the updated firmware) I used it connected to a NUC PC via USB and it frequently muted. I had to go into windows sounds settings to un-mute it. Very annoying, but at least usable. I couldn’t find a similar method of unmuting in Linux on the RPi, but I am not knowledgeable on Linux.
I’ll let you know if I get a response from HRT. The advertising literature for the discontinued Music Streamer 2 on their website boasts about how easy it is to update the firmware!

FWIW, I’ve had mine for ~6 years. No firmware updates… It just works perfectly all the time. Very strange problem you are having.


@Neil_Small , I am currently using it connected to a RasPi4 via USB and using the recently improved Volumio software to play files from my NAS. The Pi4 has better USB than previous generations now that the USB bus is not shared with the network bus. I am very pleased with this setup. I previously had it connected via USB to a NUC which was set up with ROON Rock and I was very pleased with that setup too, but I recently moved to my current setup when my ROON subscription came up for renewable.

1 Like

@Neil_Small , I’ve had mine for about 4 years. Got It used on ebay for a good price and soon learnt why I got a bargain, as the muting was evident as soon as I got it. After about a year I asked for help on this forum and @ogs kindly pointed me to the HRT update website from where I got the update which fixed the problem, but which doesn’t seem to be working now.

1 Like

If HRT does not respond to mail, the only thing I can think of is that the .bin file contains some sort of signature that has now expired. Try setting the date (year) on the PC to when you did the update and see if that works. Disconnect the PC from the network while doing this.
Chances for this working is indeed slim, but worth a try.

@ogs , the firmware zip file appears to be password protected, but I don’t recall having to unpack the archive when I updated 3 years ago. Indeed, I found a copy of the firmware download in my backup dated 2019 and this too required a password. I tried to read the contents of the firmware zip file and found a header that contained a URL which looks like a link to a server scripting file on HRT’s server. So maybe the UpStream executable can no longer reach the server where the actual firmware is.
I see from other forums that some people have had responses from HRT on other issues, so I’ll wait to see if I get a response.