I can’t get my new RPi4 with ropieeexl to connect to Roon in Settings Audio

NUC i5 with Ubuntu 20.04

Running multiple RPi4’s with hats, connected coax to other DACS, but I’m trying to connect this new Pi via usb to Denafrips Ares2.

Pi shows in Roon/settings/about, and all appears ok on ropieee web browser.

USB configuration is a little different but is supported OOB by Ropieee. If you’ve been using HATS you may have to switch back. Starting with a fresh Ropieee might be a good idea. There’s a new version.

Put another way, your problem isn’t Roon seeing the RPi/Ropieee endpoint, it’s the endpoint seeing the DAC.

Try setting HAT selection to no HAT and turning on USB on the Ropieee web page. If that’s set up right I suspect a new install for Ropieee might be best.

  1. Try another cable
  2. Attach the DAC to your NUC and check if the DAC is recognized, aplay -l
  3. If that works, same test from Ropiee. Turn on ssh under Advanced, ssh root@<ropiee>, pw ropieee, aplay -l

Thx. I’ll try burning image again first. All settings were correct.
I’d already tried burning HQPos onto sd. But the same problem, with the DAC not being recognized, hence trying ropieeexl.

Cheers Nick. I’ll re-try the ropieee image first.

I tried another usb cable already. But I’ll hook the DAC to the NUC next.

Tried two different RPi’s, they both work fine.

I’ve connected the DAC with usb to the NUC. Ran the command in terminal, but there is no Ares DAC or names for any DAC showing in the list.

I have a monitor attached now too, and can’t find the DAC.

From what I can gather, I shouldn’t need to download any drivers?

But via usb the DAC and the NUC are not communicating.

I’m in contact with Denafrips support already.

Any more thoughts of what next?

Cheers Steven,

From what I can gather, I shouldn’t need to download any drivers?

Otherwise this should be stated in the manual. I would expect Linux uses a generic driver snd-usb-audio.ko, this is part of the kernel.

Has the DAC ever played USB or anything else? It IS turned on?

Hi @steven_goodier

Can you send me feedback? You can find it on the ‘advanced’ tab.


After working through a process of elimination with Denafrips support. It appears that I have a faulty USB receiver on the DAC. Took 5 days of back and forth, and a fair bit of frustration on my behalf😄

I swapped out the DAC, and all is good. Thanks Harry

1 Like