I can't play AAC tracks

Core Machine: TS-451+, Firmware, Roon server V2020-07-15, Ram 2GB
Remote: Mac book pro 15in, OSX 11.1, 16GB
Network: Lan ethernet (cat.6)
Audio Device: Sonos Play 1, Marantz SR6006
Library: about 23.000 tracks, on NAS, no streaming service

I’have about 200 track in AAC codec, bought in iTunes store, that i can’t play on Roon.
I’ve read in the knowledge base that i should update something in my NAS but i didn’t understand what and how. Can I have support to resolve the problem?
Kind regards and thank you in advance.

Hello Paolo,

when did You buy the tracks in iTunes store?
Until April 2009 Apple used a DRM system, so the users were only able to play it on Apple devices.

Hello Alexander, the last I bought was 2 days ago (I’m Roon user since 3 weeks) and I discovered the problem. Thanks.

1 Like

Is this another QNAP that does not have the right version of ffmpeg?


Probably, here’s the specific thread

@Paolo_Zaccagnini, @crieke is very good at helping if you need assistance.

@Speed_Racer I’m writing to you while listening an AAC track with roon: Got it! Thank you very much indeed. Now I’ve to understand why Roon tells me that the source is “poor quality” while ALAC is good. They seams similar to me. Anyway, now I can listen all the tracks and that’s the main thing. Ciao


You are very welcome!!

Your iTunes AAC tracks are lossy compressed. In other words, there is some data missing compared to the lossless compressed ALAC tracks. So Roon says the source is “low quality”. Roon is correct but I find most AAC tracks to sound quite good.

1 Like

So, I have been getting notifications emails from my QNAP TVS471 saying I should update ffmpeg, but with no means of doing this in the app section.
Today AAC files stoped playing again and wonder what to do next.
Any ideas welcome?

Edit, I have managed to fix this by going to Roon app on my laptop (Windows) I followed the in app destructions to add the recommended ffmpeg file.

1 Like

Alternative guide on setting up AAC Play functionality in Roon on Qnap by adding a link pointing to Cayin ffmpeg for AMD based Qnap with QTS v5.0

Don’t know if this will help. I installed the Synology Community version of FFMPEG then created a symbolic link in the /volume1/RoonServer/RoonOnNAS/bin directory…

ln -s /volume1/@appstore/ffmpeg/bin/ffmpeg ffmpeg

To the ffmpeg binary. Then restarted RoonServer…and bingo! That resolved my Synology Roon AAC playback issue.

Granted you have to the above as root on the synology.