Roon does not read ACC files

Doing the same, I see:

grafik

Version 3.3.6 is the system default one that doesn’t support AAC.

Note: ffmpeg version 3.3.6 isn’t available from the site you linked, not even when following the link to old releases.

Please try installing a user supplied version of ffmpeg again. You can use the instructions (watch the video) found in the post below from the thread that BrianW already linked to:

2 Likes

This is exactly what I did, as described in my Aug 1 (3/8) post. You don’t seem to have read my stuff.

I’m not a computer geek, only someone expecting to have a fully working Roon without having to learn computer sciences to use it. Thus, you cannot expect that I know that ffmpeg version 3.3.6 is not the John Van Sickle AMD version.

However, as stated in my Aug 1 (3/8) post, I did import the AMD version from John Van Sickle site, click twice on it, and made the result available in the a folder on my desktop (See my post 6/8). I open the Roon Server App in the QNAP. Clicking on the ffmpeg small window, I was asked to provide the ffmpeg App in a folder created on one of the QNAP drives - ffmpeg_for_RoonServer. Did this, and finally click on “Use my ffmpeg version…”. A message appeared, saying the installation was successful and Roon was restarted. However, I still get version 3.3.6 of ffmpeg.

I don’t know what I’m doing wrong. I need help.

1 Like

Note: This is just a single file called ffmpeg out of the many you extracted from the download.
grafik

Maybe a reboot of the NAS as a such may resolve things for you. I also ping @crieke as he may have other troubleshooting steps in mind.

How do you copy the file over to the NAS? From a Windows machine, a MacOS one, other method?

Hi @Francois_Beland,
I am sorry for the trouble you have with the ffmpeg installation. It is actually already on my to-do list, to simplify this process.

Can you try to fully uninstall Roon Server in the QNAP App Center and reinstall it again? (Don’t worry, your database will not get touched or deleted when uninstalling the app.)
Afterwards set your database location again and check, if ffmpeg can be added now.

I found with my local CBC station in Victoria BC that I had to find an http site to listen to the station on Roon live radio feature, as the cbc player didn’t work

Having to delete the Roon Server from Qnap gets me extremely nervous, as deleting and installing any Apps on it. Initially, a tech guy installed Roon for me. I need some guidelines to do delete and install. Can you provide some?

Thanks.

I’ve successfully deleted and reinstalled RoonServer on the Qnap. Also, the ffmpeg version is now the “N-58069-gc253b180cb-static”.

Clikcking on the Roon interface on my iPAD, I’m asked to choose a server. The QNAP on which Roon Core is installed is identified. I click on the Connect button. An identification window opens, and I’m asked to identify myself. I do. Then, I’m said that I’m trying to install a new Roon Core. In a word, there is no way I can play Roon anymore!!!

A possibilty is that I’ve installed Roon Core on an EVO SSD disk on the Qnap, where it should have been installed in the first place and where it belong. The tech guy who installed Roon first may have installed it on the other disk, where it should not have been.

Please Help.

François Béland.

No need to worry. In the screen, that tells you, “you have set up a new core”, there should be a deauthorize button. Even though it is the same device. After that, you should see your regular Roon screen.

I am not fully sure if I understood you correctly: If you have selected a different database location in the qnap roon server window, you will start with a new empty database (because your previous database is stored in a different folder and won‘t be used. It would also explain the screen, why you have been prompted to authorize your server again.

I used the backup file from yesterday to get all my music back. All is working fine, including ACC files.

Many thanks,

François.

1 Like

Great Francois!
And I have to apologize for the initial bug, which prevented adding ffmpeg in the first place.

1 Like

I’m new at Roon. It’s a bad joke that Roon wants to collect money every month for an audio server app and then a customer should start tinkering with some codecs like in the 90´s.

This has nothing to do with Roon and everything to do with QNAP removing support for aac in their version ffmpeg which is needed to playback and decode aac on most Linux based operating systems. Roon uses FFMpeg s for support of codecs like most software does on Linux as they are not built in like Windows and Mac. Licensing for AAC is as mess and ffmpeg cannot be bundled in some regions such as the US in a commercial product. So this is not bundled with Roon so you need to install it manually. This decision by QNAP to remove AAC support affects many other apps not just Room.

Hmm, ok I unterstand. Qnap offers the Cyan Media Player Basic for 0€ with support for AAC-codec.

Maybe Roon can use this codec?

So what, I followed instructions to add FFMPEG in Vs. 4.4 from John Van Sickle into Roon-Server and it works. But the question is how long?!

I would say no it’s not.

Success report and guide on setting up missing AAC Play functionality in Roon on Qnap by adding a link pointing to Cayin ffmpeg.

Earlier I used the Daniel Murphy workaround, which stopped working for me after upgrading the NAS firmware to 5.x.x.1891.

Qnap Firmware 5.0.0.1891
AMD Ryzen processor
Roon Core v1.8 (build 884) stable

  1. Make sure that the NAS ssh service is running and enabled. Go to Control Panel > Telnet > SSH

  2. Start WinSCP on the Windows machine and press the New Session tab:
    image

  3. Set the WinSCP connection parameters as follows.

    • Make sure to select SFTP as the file protocol.
    • Make sure to have the port number the same as the ssh port on the NAS.
    • The ftp service does not have to run on the nas in order the following guide to work:
      image
  4. Press Login

  5. Navigate to /share/RoonServer/RoonOnNAS/bin/

  6. Press New and select Link from the drop down menu

    image

  7. Enter text

    • Fill in the Link/shortcut file textfield with: ffmpeg
    • Fill in the Point link / shortcut to textfield with:
      /share/CACHEDEV1_DATA/.qpkg/MediaSignPlayer/CodexPackExt/static/bin/ffmpeg

    image

    (Background info:
    the source of this path was taken from the following location.
    I have navigated to /usr/local/cayin/bin and
    pressed right mouse clik on ffmpeg > select Edit Link… from the menu)

    I could read out the path the link should be pointing to from here:
    image

    image

    I hope this will remain untouched after firmware updates

    Result after having successfully added the link:
    image

  8. Now let us restart the Roon Core.

  9. Test with a Roon client if the AAC play functionality works.

  10. Terminate the session and close the WinSCR application

    On the NAS Control Panel do not forget to disallow the SSH connection (security) by pressing the checkmark and pressing apply:

    Next step: test if it survives a firmware update.

    The content of the folder was:
    image

1 Like

Thanks. Any clues on how to do this on a Mac? I have no idea where this FFMPEG file is and how to get it transferred. I can log in via ssh. I have been through the various tutorials on how to do this but the screens all look different. My client is pretty fed up, having had no access to his AAC files for the past 8 weeks, following the system update.

grafik

It is here: https://johnvansickle.com/ffmpeg/builds/ffmpeg-git-amd64-static.tar.xz
It is inside that package and called ffmpeg.

None at all sorry. What method does your client normally use to access his NAS?

If you want a graphical interface, I think CyberDuck is an alright SCP/SFTP client for Mac. But you can move stuff from the command line using scp.

But at least for me that RoonOnNAS/bin thing doesn’t seem to be working :frowning:

[Edit]
So maybe it works after all. The file I was expecting to see was not aac after all :smiley:

Since you can ssh in, you can do almost everything on the command line…

The $ and # are prompts indicating which lines are commands.

ssh on to the NAS:
$ ssh <nas-ip> -ladmin

Select to drop to the command line (q, y)

Find the location of relevant Roon directories. Once you find something that looks about right, the search can be stopped with ctrl+c:

# find /share/ -name RoonOnNAS
/share/CACHEDEV2_DATA/RoonDatabase/RoonOnNAS
^C

So on my NAS it was on /share/CACHEDEV2_DATA/RoonDatabase/RoonOnNAS

Make sure the bin directory is there:
# ls /share/CACHEDEV2_DATA/RoonDatabase/RoonOnNAS
bin/ RAATServer/ RoonGoer/ RoonOnNAS.log.txt RoonServer/

It it’s missing, create it:
# mkdir /share/CACHEDEV2_DATA/RoonDatabase/RoonOnNAS/bin

On your Mac go to the directory you extracted the static ffmpeg in and copy it to the NAS:
$ scp ffmpeg admin@<nas-ip>:/share/CACHEDEV2_DATA/RoonDatabase/RoonOnNAS/bin/

Where the path after : is the one that’s valid on your NAS.

Go to the web ui, stop Roon, start Roon → success.

Thank you for this. I used the web file manager and copied the FFMPEG into there. This did not work. My client has given up with Roon as this was taking too long and he has replaced his Merridean Sooloos with Sonos and cancelled his subscription.