I lost Airplay on RoPieeeXL

For the last couple months I’ve not seen Airplay available on RoPieeeXL. I have a Raspberry Pi 3b with a display plugged into a Peachtree Nova 150 via USB. I assumed maybe Apple’s latest Airplay 2 isn’t compatible with the open source version? I’ve tried switching from wireless to only using ethernet – either way Airplay does not show up as an option.

I suppose the next step might be to re-flash Riopeee, but wanted to check here to see if other’s have run into this and if there’s an easier way to get Airplay back.

Have you rebooted the Pi? Has happened to me to but very rarely. A reboot always fixes it. On the other hand, when it disappears from my wife’s iPad it is usually the iPad that needs the reboot.

1 Like

Make sure that an audio output is not set to ‘Off’

1 Like

I toggled this off, rebooted, then turned it on, rebooted…

Still no luck.

I have rebooted today when troubleshooting. Also this has been going on for months, so it’s probably updated itself many times.

Need a bit more info.

Is it USB audio or any hats?
Do you use it as a regular RoonBridge and it is visible?
What device(s) do you use to look for airplay’s avaliability on it?
What network is used, router, etc.

Thanks @tudupka! I appreciate it.

  • No hat, just USB cable plugged into a Peachtree Nova DAC.
  • I use otherwise primarily as a Roon endpoint. Raspberry Pi 3B with RopieeeXL and the stock Raspberry Pi display.
  • I’m using an iPhone 13 Mini, Macbook Pro 2018, Apple TV to look for Airplay (Latest software on iPhone, updated macOS Monterey on Macbook Pro, and latest software on Apple TV). I used to see the Airplay in all these places with Apple Music or otherwise a sound output available.
  • Network: RoPieeeXL is connected via Cat 5e ethernet and wireless (but currently just connected via wireless for troubleshooting). Centurylink Fiber Internet with Axon C4000XG that was provided by CenturyLink, and a Netgear gigabit 8port switch providing ethernet to various computers, HDHomerun.

Now that I’ve made that list, I do wonder if the new Centurylink branded router is somehow blocking Airplay. Other Airplay recievers are available on the network (homepod, Apple TV, Macbook) though. I disabled whatever ‘Cyber Security’ setting they have in here is as I’m reading on Reddit that it can interfere with Apple’s Bonjour networking, but so far no Airplay is showing up.

OK, I just want to report that I figured out what the issue was – or at least stumbled on making it work again after reading this post on reddit on this router.

I had RoPieeeXL set using both Wireless and Ethernet, and I’m guessing wireless took priority. The new Centurylink C4000XG Wifi 6 wireless router was set to use 802.11ax wireless. I set it back to 802.11ac compatibility, and the RoPieeeXL Airplay shows up. Switching that around seems to have made Airplay available. Oddly I put it back to 802.11ax mode and Airplay still works, so maybe it’s a matter of jiggling the handle there and knocking something loose. As well as turning off the ‘Cyber Security’ setting in this particular router (Centurylink branded Axom C4000XG).

Moral of the story: Maybe the router that comes with your ISP isn’t that great.


Switching that around seems to have made Airplay available. Oddly I put it back to 802.11ax mode and Airplay still works
I’d be careful with that, it might be still working because the device is already was cached, as soon as it is reset or cache expires it will disappear again.

Would also use wired ethernet if possible, but in you case it looks like some security feature blocks ports/traffic, so wired/wireless is probably the same.

1 Like

Following up on this, I lost Airplay again. I just don’t understand what exactly makes it able to work or not. Maybe I’ll try re-flashing RoPieeeXL.

If re-flashing does not help, first I’d disable WiFi in RPI and use ethernet only. If that doesn’t do it, try the same thing as last time, switching your router to 802.11ac mode.

Thanks for your help @tudupka, I really appreciate it.

I’ve had both 2ghz on 802.11b/g/n and 5ghz on 802.11a/n/ac (turning off the 802.11ax option for each) in the wireless router.

Using just Ethernet, or just Wireless in RoPieee – it doesn’t seem to matter. I’ll reflash here sometime soon and share my results with the community.

FYI, I did reflash RoPieee, FYI. Same issue. RoPieee XL is using ethernet to connect – no WiFi. Someday I’ll try a different router other than the stock Centurylink C4000XG – as no settings there seem to work consistently. I’d love to be able to use RoPieee to stream audio from the Apple TV to my stereo via Airplay.

I’m wondering if this was solved. My airplay was fine, and then I saw I had a Ropieee update. After the update, I lost Airplay. I have rebooted Ropiee, and my Mac.

Next, I’ll reboot the Raspi 4.

RoPieeeXL 2023.11 (1168)

Same here, Airplay is no longer shows up.

I see that the latest ver should be 1176.
Do I have to re-flash the card to get it, because my RPI3 does not see any new updates in the “Stable” update channel?

Just wait for it. It can take a day or so.


1 Like

Yep…mine took a few hours, but eventually it showed up

1 Like

it has been over a day, still not showing up :frowning_face:
tried to reboot a few times, still nothing

Just be patient, there are thousands of ROPIEEEs out that needing to be updated…I’m waiting too, takes 1-2 days sometimes :wink:

1 Like

2 days+
No update :cry: