iFi iDSD Micro native DSD support in RoPieee

Yes, I did. Feeback is on its way. Identifier f7f70e7572c55518.

Another strange issue is that a max DSD Samplerate of DSD128 is shown in the Device Setup in Roon although the iDSD Micro is a DSD512 capable DAC…

That depends. One of the downsides of DoP is that it requires more bandwidth than native DSD, so that can be the reason. DSD512 is natively also not possible on a Pi because you’re then maxing out on bandwidth.

Ah, ok. Did you see anything in the feedback?

Yes. This is Xmos problem. :frowning:

To be able to do native DSD on Linux the kernel needs to be patched. This is something that I’ve done for a range of devices (see website), including the IFI DAC’s. This patch recognizes the DAC by it’s USB ID and then makes sure the audio is sent to the endpoint in the DAC (“altset”) that supports a native DSD stream.

Now, it seems that IFI has devices that use different altset’s: you’re DAC uses 2, while my black label iDSD uses altset 3. That shouldn’t be a problem, unless you use the same USB ID for that. In that case the kernel can’t make a distinction between the 2 devices. So either I patch the kernel and your IFI works, or I patch the kernel and my IFI works. But not both :frowning:

This should be solved by IFI. They really should use their own USB identifier AND device identifier in stead of a generic XMOS one. Or make sure on all devices the same altset can be used for native DSD.

So sorry for this, but this is not gonna work without them changing stuff.

What a pity :weary::weary::weary:

I think jussi laako may have solved this with a change he made to the latest kernel? Have a look at his latest native dsd related changes.

Thank you very much for your help. Found a solution for my „problem“ :grinning:

Hi Sean,

Where can I find those?

And @dabassgoesboomboom,

this is related to the change I made for your device… So which model do you have exactly?

Hi Harry, as mentioned further up in this thread:

Have a look here, at the generic detection:

https://patchwork.kernel.org/project/alsa-devel/list/?submitter=111

1 Like

Hi @Jens_G,

Curious what your solution is.

Anyways, I’m gonna build a new kernel during the weekend. If you’re up to it you could test that.

Regards Harry

Hi Harry, to be honest I gave RuneAudio a chance an it works flawlessly and as it should. Obviously it is indeed a matter of the Kernel. By the way: once again Thanks a lot for your help and support.

Kind regards,
Jens

Hello Harry, when do you think the new Kernel will be available for testing?

Regards, Jens

Building as we speak. I expect tomorrow or Monday.

Sounds good. Looking forward to testing :+1::grinning:

Hi @Jens_G,

There’s a new kernel in the beta channel. This means you need to switch to that one (in the ‘advanced’ tab).
I suggest you also put the update mechanism on ‘manual’, so you’ll be noticed in the web ui (after a while) of the update being available.

I’ve tested it on my Ifi Nano iDSD BL and it works.

Looking forward to your feedback!

Regards Harry

Hi Harry,

excellent job. Now it works like a charm. Thank you so much. I love RoPieee :+1::grinning:

Regards Jens

1 Like