Ifi Micro iDSD Black settings in Roon + Tidal

Hi everyone,
I have recently purchased an IFI Micro iDSD Black Label and I would like to know if my settings are correct and also maybe to understand a bit what it’s showing to me in the below screenshots.

First, to explain a bit my setup:

  1. Roon server is located on a big gaming desktop which I am using at the moment only for Plex and Roon (because I don’t play games anymore :slight_smile: ) Here I stored all my FLAC files and also I have connected it to Tidal.
  2. I listen to music through my laptop where the IFI DAC is connected.

First 2 screens are with my current settings:

And this is the Signal Path description:

If anyone can help it would be great.
Thank you.

If you want, the iDSD BL can support PCM768 and DSD512, at least my non-BL iDSD can.

I’ve had nothing but trouble with my iDSD, in that the battery will not stay charged. The pisser is that even when plugged in, which mine is all the time, if the battery is down the DAC won’t play.

If you find you have battery troubles there are some settings, all of which I can’t remember, which will help somewhat. At the least, lowering the res will help.

One the other hand, I just may have a lemon.

Have you tried to run device setup and select your device? It would set what is supported automatically. I believe I read to use Native you need device drivers installed on your laptop. There is also a firmware update for your device have you done it? Just some stuff to try no experience if you are a gamer might be stuff you are used doing. Pretty sure if you go over to iFi website the is further details on how to setup. They have manuals and tech notes I think they call them. Hear good things about that dac.

I’ve opened a support ticket awhile ago. As of now, I don’t feel like hassling it. I’ve already sent it back once because of a bad USB port.

When I use it, it’s plugged into the wall thru an iFi USB3.

I charged it according to the instructions I was given when I first reported the problem. That method worked for awhile.

Next time I bother to deal with them I’m going to ask if it can be rewired to work without a battery. Probably not.

It’s definitely capable of running fully off USB power alone…

I’m guessing the instructions they sent you were as per the manual? Connect USB cable to DAC and computer first, then power on last?

Yeah, I always ran it that way, but maybe I forgot about that the last time around.

I’ ll have to revisit that, tomorrow.

Thanks for the heads up.

Oh yeah, the instructions they sent were a long involved process about how to recharge a depleted battery, which last I tried didn’t have any effect.

1 Like

Yep, won’t help if the DAC is already on before connecting to USB power. The sequence is critical.

Hope that sorts it for you when you retry. It’s a nice little DAC/Amp.

1 Like

Not with the MQA firmware loaded. You have to choose whether you want MQA firmware (supports PCM384 and DSD256) or the separate firmware for PCM768/DSD512.

Everything looks good!

The iDSD can only function as an MQA ‘Renderer’ - it can’t do the full MQA decode. So you can select ‘Renderer only’ in the Roon MQA settings but it’s working fine as a Renderer already with your current settings anyway, so it’s fine.

I assume you’ve deliberately applied -9.5dB Headroom Management and deliberately applied 10 band EQ for your own reasons. If that’s all deliberate, then I’ll leave that alone.

Everything else looks normal and good.

1 Like

Ha, I never should have got involved in this thread. Sorry, @Andrei_Golea for the confusion. I’ve never contemplated using MQA.

@dabassgoesboomboom, I tried your suggestion about connecting then turning on, but no joy.

I guess I’ll re-open the incident report I have with iFi.

1 Like


Much happier news with Pro iDSD I hope? Latest firmware fixed any prior issues?

1 Like

I haven’t put that on and probably won’t. Although I updated with the firmware prior to the newest (didn’t change anything) the whole process on $2500 worth of DAC, creeps me out.

Really, the only problem is that the tube mode doesn’t seem to work, but I just read where iFi recommends waiting a half on hour before trying to use in tube mode. Haven’t gotten around to testing that.

Just re-realized that there is a BNC for an external clock. :face_with_raised_eyebrow:

Did you see this?

This is the first public downloadable firmware for Pro iDSD they’ve released and it has some quite significant changes. I trust that it’s reliable… but funnily it’s still ‘beta’ :grin:

Yeh I saw that. Unless I need to sync multiple DACs I’m really not interested in using external clock input with any DAC.

His system chain is epic. There’s just too much happening for me.

I see where SOtM’s SMS-200ultra also has an external clock BNC.

Ah, the dark side beckons.:worried:

Time for some :sleeping:, later.

1 Like


Don’t step onto that side brother. We’ll have to physically hold you back if we have to. I fear there’s no coming back from that side… :grin:

Peace, until later

1 Like

Thank you so much @dabassgoesboomboom

You are right, those settings were done by me based on the tests performed by the guys from InnerFidelity.
To be honest, after I applied that EQ the Sennheiser HD660S headphones sounded much much better.
And also, from what I understand, the -9.5dB Headroom Management was done to prevent clipping or something like that. The only thing that can be considered a very small inconvenient is that now I have to rotate the volume dial a bit more :slight_smile: but the sound is angelic (especially when listening to Tidal Master quality).

I have the iDSD black and I think I found the solution
( LED in IDSD changes accordingly )
I Turned the Rate convention option on .
( Headroon and filters don’t affect , set them as you like )

Welcome…but this is a pretty old thread. I’m surprised that the forum allowed you to wake it up. :slight_smile:

I’m a bit confused by your highlighting of DSD upsampling since I believe Roon ignores this when playing MQA content to an MQA DAC

Hello David ,
Yes … I noticed that is a very old thread … afterwards :slight_smile:
I was looking for MGA settings too.
Enabling DSD upsampling, is the only way to see that MQA works with iFi micro BL