iMac unable to run Roon 2.0, need assistance moving Nucleus to 1.8 Legacy

I installed it on an iMac with Mac OS 10.15, but nothing works anymore.

On an older mac you can’t install. My macmini is old, still perfect but unable to run version 2.0. Dedicated to roon for many, many years. Now I can throw it away. And no music, either.

It can be fixed. There is a version of 1.8 that’s been released. It’s 1.8 (Legacy). You need to download that and run the install on your core (always do a backup) and then download 1.8 (Legacy) software on all your other devices.

Here is some reading

If you get stuck we are all here to help.

I tested without wifi and accessing using 5G. Then using ARC, I can reach my core and play music on my iPhone. But inside the network, the remote app won’t connect at all.

I included a screenshot above. It is still the same.

I’m also stuck in a similar situation—all my iOS Roon remote devices updated to remote 2.0, but my iMac is capped at High Sierra and thus cannot support the 2.0 core. So now I’m screwed it seems unless the remote is updated to be compatible with 1.8 core. Pretty weak, Roon. Everything worked great on 1.8. I had zero complaints. Please address this soon!!

It has been addressed surely? Install 1.8egacy version.

1 Like

The resolution for this is to downgrade and the steps/links you need are above in this thread.

You can downgrade your remote by uninstalling and searching the app store for “Roon Legacy”

But I would expect it would function properly on a mac running big sur. It doesn’t, as the new 2.0 remote app can’t connect to it. It’s visible, but that’s all.

I would start a new topic if you haven’t already so support can help you. You might be lost in this topic.

1 Like

I’ve been away for a couple of days but I’m now looking at this problem again. I’m cheered to see that there’s been widespread outrage!

It looks as if I need to regress my Nucleus to ROON 1.8. However, how do I do this whilst my iMac is speaking ROON 1.8 and the Nucleus has upgraded itself to ROON 2.0? My iMac can’t connect to my Nucleus at all.

I think you are mistaken… over 100,000 people are successfully using ARC, and many more, Roon 2.0.

The instructions were posted earlier…

Dear Martin

I have today switched on my music playing system again. Some sort of automatic updating occurred and I now find I can control my music, through fully functioning ROON, using my iPad and iPhone. I am greatly relieved that I am no longer condemned to silence. However, I still have no control through the ROON application on my elderly iMac.

Please can you try to help me understand what is going on.

Here is a screen shot showing the dialogue box I am being shown. I don’t know whether it is visible to you as it appears above as a bunch of text and numbers, even though I have ‘dragged and dropped’ the image as advised.

It would seem that my iMac is incapable of downloading and running the controlling software for ROON 2.0 (although my iPad and iPhone have successfully done so). Are my options:

  1. To leave my ROON Nucleus with ROON 2.0 and control my system using iPad and iPhone, acknowledging that my iMac will never be capable of doing so.
  2. Regress my ROON Nucleus, iPad and iPhone to ROON 1.8 so that I can continue to control the system with all three Apple devices?

Do you really need 3 control devices, it’s obviously preferable, but treat the Nucleus as King and maintain access and control at Roon v2., then you will retain the option to use ARC.
If you need access to your music on the odd occasions that internet access is not available then you will need to revert all devices to Roon v1.8x.

You don’t mention the OS on your iMac, so it may not meet the current Roon v2 specification, full details are here :- Roon Specs

If your iMac is up to specification then you could try removing the app then download & reinstall it which may overcome your problem, Roon 1.8x can’t “talk” to v 2.x

Hope this helps :thinking:

I use Innuos Sense on my main system and they have just implemented uPnP so that and Innuos device can send to multiple devices. Sense’s settings have a switch to switch uPnP on and off. All that is then required is to reboot the device and it will revert to standalone mode.

If Innuos can do it, Roon should be able to do so as well.

There may be 100,000 people with ARC, I’m probably one of them, but only because I can’t work out how to roll back to 1.8. There is a link to QNAP (instructions), but it is an app file and not instructions.

Dear Paul

I am grateful to you and any other fellow-sufferers who attempt to help. In answer to your question, it has now become clear that my iMac is simply too old every to take the ROON 2.0 upgrade.

And you’re right, I can probably make do with two control devices. However, I most often listen to music whilst working at my computer and it is more elegant to control the music system from the same device.

I appreciate your advice that ‘…you could try removing the app then download and reinstall it…’ However, I don’t know how to!

To delete, using Finder, locate the Apps folder, find Roon, and move to this to Trash.

To find tour version of macOS, from the Apple menu  in the corner of your screen, choose About This Mac. You should see the macOS name.

Let us know the name or version number, and we can confirm if Roon 2.0 can be installed.

@Steven44, if you have a problem that requires support please open a thread in #support. Likewise, if you have feedback, please use the #feedback category.

However, please don’t start a new topic in an existing thread; either start your own or reply as a linked topic. Thanks.

It says: macOS High Sierra, Version 10.13.6.

In this case, you are unable to run this Mac as a Roon control device, so remove Roon as described in my last post, and use your other two devices for control.

1 Like

Hello and thanks for the suggested fix.

My Nucleus+ is now on 1.8 legacy and can be operated via the 1.8 legacy iOS app.

I now try to follow the instructions on the FAQ page to upgrade 1.8 legacy to 2.0

My problem: I connect to smb://IPADRESS as “guest” but don’t seem to find the /DATA folder to put the 2.0 installer there.

Any ideas?

FWIW, from my (and other’s) experience on ROCK those instructions may not work.