iMac unable to run Roon 2.0, need assistance moving Nucleus to 1.8 Legacy

Roon Core Machine


Networking Gear & Setup Details

I don’t know what most of these words mean.

Connected Audio Devices

Novafidelity X45

Number of Tracks in Library

Lots of tracks.

Description of Issue

This morning I have switched on my HiFi system, as usual. Something weird happened with Roon - I was offered an update as has happened often in the past, which I accepted. I then tried to play music (Roon’s CORE function, although this often seems to be forgotten). I am told through various dialogue boxes that something is now incompatible. Much of it makes no sense to me whatsoever! I think the problem lies between my elderly iMac and my expensive ROON Nucleus. I THINK my iMac is unable to upgrade to the latest ROON OS, whereas my Nucles has already gobbled it up. There then follows horribly complex instructions on how to return the Nucleus to its previous state. In the meantime I CANNOT PLAY MUSIC. The urgent admin task I must do today cannot have a musical accompaniment. WHY ON EARTH WAS I NOT GIVEN A BIG RED FLASHING WARNING NOT TO ACCEPT THE “UPGRADE”? Is there an easy way I can return to the status quo ante or must I invest a number of hours going through the complex instruction which I do not understand. I AM VERY ANGRY!!!

1 Like

Do you have Roon Remote on a mobile phone or tablet? These, once updated, will work with your Nucleus.

Same here. I had Roon running on a MacMini for years. But now, it won’t work anymore. My tablets and iPhone auto-updated to 2.0. My core runs 1.8. In no way are you able to connect anymore.

I then decided to install it on an iMac and restore the database from the MacMini. The DB restore worked, but my app on the iPhone won’t connect. It shows 2 cores - both on the iMac as I switched off the MacMini. Then downloaded ARC. I was instructed to use UPnP on the router - which I deliberately switched off. Installed a port forwarding on port 49200 to the IP address of the iMac. The Roon app on the iMac then tells me everything is ok.

But no, when I start ARC on the iPhone, I also see two (?) cores. None of them wants to connect.

So, in conclusion, I have a lifetime license that I can’t use anymore. Thanks a lot.

Roon 2.0 app - not able to connect

Roon ARC - after selecting one of the cores - it won’t connect

Dear Martin

I’m not sure whether you are a ROON representative or a kindly fellow-sufferer?

My iPad and iPhone are slightly too old also. So it looks as if I need to take my Nucleus back to 1.8. The instructions describing the process may as well be in Chinese! I suspect I will need to allocate 2-3 hours to trying to decipher it all, until when I cannot listen to my HiFi!

It’s exasperating that these techno-boffins expect us to be tinkering with our software all the time and fully au fait with the darkest recesses of their various programmes. Most of us install stuff and then forget about it whilst we LISTEN TO MUSIC. I have no memory of how to get into the troubled psyche of my ROON Nucleus to regress it to 1.8. If anyone has time to write an idiot’s guide it would be gratefully received.

1 Like

8 posts were split to a new topic: Roon 2.0: Can’t Connect to Core

I am a fellow Roon user and volunteer moderator.

Please note that Roon 2.0 has no restrictions on the devices; if they run 1.8, they will run Roon Remote 2.0. If you shared the models, I can check for you.

Also, if you okay being patient, I’ll take a look at this tomorrow; it’s time for my bed now.

Odly enough also from NI and largely share David’s sentiment. Phone has auto updated to 2.0.can no longer see Roon server.

Just need straightforward advice on how to correct an issue that should never have been allowed to occur in first instance.

I was told 2.0 would be a game changer…Well that much is correct!

Dr. Lewis, assuming you have an iPhone and that you were able to run V1.8 on it, did you download the newest Roon app from the iOS App store?

There’s also an app for Android, but I can’t speak to that.

Dear Martin

I think there are a few angry people around! Is there any way we can escalate this to a Formal Complaint and perhaps get some sensible advice from a senior ROON person?

Martin is offline.

I am tagging @support.

For those of you in this thread who are running older Macs and Mac Minis you may not be aware that you have to be running the Catalina OS. Most of my Mac machines, including my Mac mini that was running Rune 1.8 were running on Mojave. I needed to upgrade my mini to Mojave in order to upgrade to begin the upgrade path to Rune 2.0 & ARC……FWIW, this wasn’t made very apparent by Roon…at least in my opinion.

Whoops…meant upgrade to Catalina…not Mojave😏

I think for some people in this thread that is a big part of their complaint.

I installed it on an iMac with Mac OS 10.15, but nothing works anymore.

On an older mac you can’t install. My macmini is old, still perfect but unable to run version 2.0. Dedicated to roon for many, many years. Now I can throw it away. And no music, either.

It can be fixed. There is a version of 1.8 that’s been released. It’s 1.8 (Legacy). You need to download that and run the install on your core (always do a backup) and then download 1.8 (Legacy) software on all your other devices.

Here is some reading

If you get stuck we are all here to help.

I tested without wifi and accessing using 5G. Then using ARC, I can reach my core and play music on my iPhone. But inside the network, the remote app won’t connect at all.

I included a screenshot above. It is still the same.

I’m also stuck in a similar situation—all my iOS Roon remote devices updated to remote 2.0, but my iMac is capped at High Sierra and thus cannot support the 2.0 core. So now I’m screwed it seems unless the remote is updated to be compatible with 1.8 core. Pretty weak, Roon. Everything worked great on 1.8. I had zero complaints. Please address this soon!!

It has been addressed surely? Install 1.8egacy version.

1 Like

The resolution for this is to downgrade and the steps/links you need are above in this thread.

You can downgrade your remote by uninstalling and searching the app store for “Roon Legacy”

But I would expect it would function properly on a mac running big sur. It doesn’t, as the new 2.0 remote app can’t connect to it. It’s visible, but that’s all.