Increase buffer? (To help with sketchy internet connection)

Hi all

Hi have a sketchy internet connection where on some occasions roon wiil skip to next track is there a way of increasing the buffer size


More information at:-

You are referring to the RAAT buffer fort the endpoint. That won’t affect a sketchy internet connection when streaming, only the local network buffers.

I am not aware of any settings affecting the incoming buffers for streaming sources. The Core will always cache the full track though, and pre-load the next in queue right before track change.

1 Like

You might also reduce the audio streaming quality.
I do not have Qobuz if that is what you are using, but for tidal see below.
In Roon you can go to Settings\Services and edit Tidal:

In Tidal app it looks like this:

1 Like

There are similar setting in Qobuz…


hi thanks for the reply

im not very computer savey so im a bit lost

the problem i have is track stops playing and a message comes up something like qobuz is having trouble loading due to network problem

my internet generally runs at 15 - 30 mbps

what is the cause of this loading error

Ram maybe only have 4gb

This isn’t necessarily down to internet it more often is your internal network setup and Roon infrastructure. You have not said how your system is setup. Is your core locally attached to a DAC or are you sending audio to other devices over the network. How is your core connected to the local network, how are you audio devices connected to the network. What is the setup of your network hardware? Roon is demanding on the local network especially if WiFi is in the chain. So let’s see what your doing and then we may be able to better diagnose areas to focus on.

my system is
laptop running roon wired connection to the router
usb from core to dac

Thanks, that’s as basic as it gets then. Tidal or Qobuz? What region are you in? Do you get any issues using their own apps to stream to same DAC? Are you using any DSP?

sorry its Qobuz
im in the uk
never tried there own app
whats a DSP

1 Like

Roons DSP ( Digital Signal Processing) if this is active it can affect performance if the core is not up to Roons recommended spec as the CPU can become bogged down. If you don’t know what DSP is unlikely you have it on.

One thing to try which has worked for others although not supposed to be necessary with the latest version is to change the DNS server settings for your network in your router if it allows it or on the pc that’s your core to use a different service than your internet providers. Recommended one is If your not overly network savy and don’t know where to change this then maybe avoid.

I would try the Qobuz app and see if this can maintain stable playback as it will help rule out if this is Roon or as you first thought your internet.

Who’s your internet provider? Have you tried using a different ethernet cable? Or a different USB cable ?

thanks for the help
i will check out your suggestions later
i have run task manager to see what is going on my memory is running at about 90% CPU is like 5%
would it be the memory was thinking or upgrading to 8gb from the 4 gb i have

Can’t harm to upgrade it 4gb is pretty low more memory Roon has the better, but whether it’s the cause of your issues I don’t know.

1 Like

Is the laptop windows or mac? If it is windows, 4Gb of memory is pretty low. I would recommend at least 16Gb if the machine is also the Core and on a Windows OS. What laptop is it? Is it fairly new or and older one?

Hi windows 11 laptop and its just used as the roon core HP laptop 3 months old

Yep, definitely worth upgrading. The minimum recommendation for Windows is 8GB. As @CrystalGipsy mentioned, this may not be the cause of the problem, but it will certainly help prevent other issues.