Installation on DSM6 fault

Hello Roon Community,

After having reinstalled my Synology 716+II with DSM 6, I wanted to install the Roonserver.
Therefore I used version „RoonServer_Synology_DSM6_x86-64_2022-05-14.spk“
and tried to install it manually. Thereby the following error message occurs:

Installing with a Legacy version however works perfectly.
Does somebody receive the same error message or may give me an advice? There are no problems with an internet connection and DSM6 works also properly.
If I try to open the URL with the browser, the ordered website seems not to exist.


Hello @Markus_H and welcome to the forum.

Please check your internet connection (firewall, antivirus and/or malware detection software, …).
I had absolutely no issue downloading said file from this URL.

Curious that the URL works for @BlackJack because when I try the URL from the screenshot with,, I get a “site not found”.

In fact, neither the secure nor as such works - site not found.

The download link for RoonServer-Linux on Roon’s KB for Linux install points to the top level domain,, and this works.

Going to https or works as well: redirects to gets a “403 Forbidden”, i.e. it exists

I have no experience with the DSM install, but from the description it seems as if the DSM package tries to auto-download from the URL, correct? Might Roon have changed the download domain to .net but the DSM package still uses the .com URL?

Maybe I was just to sleepy when posting?
Anyway, if the URL in the package is outdated, @crieke needs to release a new package to correct that. In the mean time: If you’re able to download Roon from the link Suedkiez posted and place it into the /tmp folder then start the RoonServer package installation again, it should be recognized and the installation should finish.

1 Like

Dear BlackJack and Suedkiez,
I highly appreciate your advice. I followed all your suggestions, however, it still does not work and I have no clue why, although I think day and night about the problem :-(.

I don’t know too. To place the manually downloaded RoonServer_linuxx64.tar.bz2 in your system’s /tmp directory where the installer form RoonOnNAS expects it, is a known workaround for situation where the automatic download fails and has so far worked for many users. So just try again, try harder? Is it still the same error?

UPDATE: /tmp is wrong for the workaround the manual download has to got to /public.

All the links in my above post, including the ones going to .com sites, are working now. As they also had worked originally for @BlackJack, I suppose that there may have been a temporary misconfiguration of the sites when I tried, possibly by Roon. (Or the Cloudflare DNS I am using messed up).

If this is the same for you, this link should work again and it should download the RoonServer_linuxx64.tar.bz2 package:
Does that work for you?

If yes, then I don’t see a reason why it would not work when you install the Synology spk package, as this seems to be using the same link to download RoonServer_linuxx64.tar.bz2

1 Like

Dear BlackJack and Suedkiez,
Thank you once again.
Now, I have been successful. The above link does work. I also think there must have been a temporary misconfiguration of the sites the last days.

1 Like

Fantastic. I hate unlucky coincidences like that :slight_smile:

Me either. That was nerve racking :exploding_head:.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.