Installing Roon GUI On Linux

@Martin_Webster Just tried it. It said “This device is not compatible with Roon 2.0” during setup :smiling_face_with_tear:

@abbluiz, I’ve moved your last post to a new thread, as the discussion is moving off-topic.

If you’d like some assistance from the community, please provide some information about the distro you’re using and what you have tried so far.

Distro: Fedora 36

I installed wine and winetricks from the default repositories of my distro and then
I simply went to GitHub - RoPieee/roon-on-wine: Running Roon with Wine on Linux and tried to run the script.

It stops in a window “This device is not compatible with Roon 2.0”

Nevermind. There’s a fix for that, explained in Can't install Roon 2.0 · Issue #26 · RoPieee/roon-on-wine · GitHub

1 Like

The minimum requirements for Roon 2.0 have changed: Windows 10 and 64-bit only.

Roon GUI runs without problems on Ubuntu and Fedora using Crossover from Codeweavers. I had to install the Microsoft.NET framework 4.6.2 in the bottle to get it to work. I haven’t tried setting it up using Wine directly.

Anyone knows how to install Roon on NixOS?

Give Roon on Wine a try, or install manually.

Note the dependencies, and that you’ll need Wine staging.