Installing Roon on UBUNTU Linux, I can't get the easy installer to run

Sorry to have to start a new thread, but I could not find any help any other way.

first off, I am completely ignorant on Linux. I installed Linux (full install) on an old laptop to simply serve as my Roon machine, nothing else.

I tried to follow the instructions from the roon site but it was not clear to me.

I’ve down loader the file “roonserver-installer-linuxx64.sh” I’ve moved it to several different folders to run it from. Home, the desk top, downloads. to no avail. I’d set permissions to “run as program”

in the Terminal window I’ve used the command “chmod -x ./roonserver-installer-linuxx64.sh” with the file not found error being returned.

in the Terminal window I’ve used the command “sh ./roonserver-instaler-linuxx64.sh” with the file such file error being returned.

Is there a specific folder the file should be in?
Do I need other programs installed to get the script in the file to run?

Any help would be greatly appreciated.

You should simply run “sudo chmod +x roonserver-installer-linuxx64.sh”, without the ./

After, you run “sudo ./roonserver-installer-linuxx64.sh”

See if it works

Are you using the desktop version, i.e., with a graphical interface?

If so, when you downloaded the easy installer, it was probably saved in the Downloads folder. Please confirm if this is the case.

Now, from the command-line, type the following:

cd ~\Downloads
chmod +x roonserver-installer-linuxx64.sh
sudo ./roonserver-installer-linuxx64.sh

This should run the installer.

1 Like

It asked for my password, but I was not able to type anything in for a password.

What do you mean? You don’t remember your password, or you can’t see what you type?

Enter the password you used when installing Ubuntu, and then press Enter.

It will not let me type any characters at all. I tried pasting it in and that did not work.

Thanks for the help

Oh the password does not show when typing, It worked, sort of. I got a message that the installer did not complete successfully. curl command not found. is that a command/function I need to install?

I’m going to download it again and try another time. Thanks for the help. Much appreciated

Thank you Martin and Jose. Still working on it I need to install ffmeg and hopefully that will take care of it.

Tom

Almost there,

I got an failed error, “checking for the mount.cifs command FAILED”

What does this mean, this is the only error on installation now.

success! I’ll shut up now. problems solved!

3 Likes