Interface on Roon not displaying correctly after update

Core Machine (Operating system/System info/Roon build number)

Windows 10 pro/Lenovo Thinkpad X1/Roon 1.8 (most recent update)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Sonore Signature Rendu - USB

Description Of Issue

Since the update, Roon app has horizontal green lines through all text/graphics. I’ve tried uninstalling roon and re-installing; still no luck. Any suggestions? Also my iPhone is no longer recognizing the Core at the office; no issues prior to the update

Not sure if it matters, but I also use Roon for my home system. I haven’t had any issues on my home system after the update; iphone recognizes home PC as core, no app interface issues, etc.

From other posts I have read on this same issue, the fix is to download and install the latest GPU drivers from Intel Intel® Driver & Support Assistant. Here is a link to another thread some more information and a workaround if you don’t want to install new drivers Green line display artifacts in 1.8 [Intel Bug, Update Your Drivers] - #31 by George_Abrahams

1 Like

Although, I appreciated the credit, a point of clarification the fix was provided by Roon Lab support Allan Hsu.

“If you cannot (or do not wish to) update your GPU drivers, you can disable 30-bit color on Windows by adding the -nodeepcolor argument to the application shortcuts that you use to launch Roon.”

1 Like

Hey @Jason_Laney,

Thanks for your clear report. It looks like both @AnimalOnDrums and @George_Abrahams had great suggestions.

Please, let me know if any of those help :slightly_smiling_face:

1 Like

Adding -nodeepcolor argument was the correct answer for me. I updated all my drivers and still had the same issues. Added the nodeepcolor and now working as expected! Thanks @George_Abrahams and @AnimalOnDrums


Thank you @Jason_Laney for taking the time to give those solutions a try. Delighted it worked!

Thanks again @George_Abrahams and @AnimalOnDrums :pray:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.