iOS App is crashing permanently

Hi! I hope you can help…

Core Machine (Operating system/System info/Roon build number)

My Core Machine is my iMac late 2017. Im was using this as my core since I start using roon…3 years ago I guess.
Some weeks ago I bought a synology ds1621+ and tryed to use this as my core - to have roon without my iMac running.
But then I got the permanent iOS crashes and first thought, the synology is the problem…and moved back to my previous working system on my iMac…but the crashes kept - so the synology might not be the problem

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

I used some airport express as endpoints since I started using roon, with no issues anytime!
Some weeks ago (to be exact, the same day then my synology) I bought my first raspberry pi with a hifiberry dac to start moving to raat as my streaming protocoll…
The same story - I thought maybe the hifiberry causes the issues and so I deactivated it (on my old working iMac system)…but the permanent iOS crashes are still here!

My Network containts a synology router (rt2600) as dhcp and gateway, two managed switches from netgear and 4 synology mesh routers (mr2200) spread to my house.
This setup is working for some months now with no issues.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

As mentioned above, some airport express endpoints as audio devices for roon. And the new hifiberry.

first I loaded ropieee on my pi, but the hifiberry dac i bought was not working properly (the new DAC2 HD), so I switched to the hifiberry OS, which is working just fine. I will try ropieee some day again, maybe after some updates my dac2 HD is working…i would prefer ropiee because of the display option.

Description Of Issue

Finaly, the issue. Roon crashes on my iphone, and on the iphone of my wife - permanently, after some seconds of using…i we can start a roon stream, even to the hifiberry in this seconds, the music is running…just the app crashes.
I tryed to reinstall, reboot, coldstart,…nothings worked, still crashing.

And because I switched back to my previouse working setup, even without the Pi…the issue remains!! And thats what makes me crazy…because I have no idea what the problem is - everything was working fine for years!

Thanks for your help!

Hi Andreas,

I assume you are German as I am but I will answer in English because of compatibility with the forum.

Although I have no particular answer, I would recommend to reset the network settings of your iPhone. From personal experience and others I’ve learned that iPhone are quite „sensitive“ to any changes in the WiFi network, even minor ones, resulting in temporarily losing the network connection, which could cause your Roon remote to crash.
In your case I would try this first.

Be aware that if you do this you need to have your network access logins at hand for everything you use for iPhone for (e.g. also VPN in case…) as you will need to input them new.

Good luck!


I hope you are assuming my language because of my name…:wink:

Thank you for your quick answer!
I will try that…and report.


Yes I did, no other reason. :slight_smile:

Hope it helps!

Hi @Andreas_Strobl,

Can you please provide some more details regarding these iPhones? What is the exact model and iOS version?

Are your running any apps in the iOS background? Does Roon still have issues if you force-quit your background apps?

newest iOS-version on a iPhone 11 pro max.

I did a reinstall the app, but this did not help.
But I found something different. It seams, that the Wifi connection of one of my endpoints was not very stable…since I gave him a cable, also the iOS app works better…
I will look onto this issue for some time, and try to install another hotspot to light up my wifi in this area of my house.
Lets see what happens!
Thanks for your fast response!

1 Like

Thanks for the update here @Andreas_Strobl, do let us know if the Ethernet connection helps!

I get now some new component and could test some things out.
Now I definitly know, that if I turn on the Wifi on my Raspberry Pi the iOS crashes happen.
It does not depend on the software running on the Pi, because I tested Hifiberry, Ropiee and finally using ropieeeXL…always the same.
I bought a new switch and now I am using cable connection to the Pi only - and now the App is not crashing anymore…if I switch on Wifi again…the problem repeats.

So this must be a Raspberry Pi thing? I was using the onboard Wifi, by the way. Maybe a external Wifi would solve this, but now I am happy with cable.

Soon I will deploy some more Pi´s on my house, and at some positions I have to use Wifi. I hope it will work fine then…lets see :wink:

Thanks for your help!

1 Like

I have another tread, pointing on some (now solved) raspberrypi issues.
Before solving, it was not clear, if the iOS crashes are caused by some Pi-software or not. But now its clear, that not the software is the problem.

1 Like

Hi @Andreas_Strobl,

This is a very interesting observation, thank you for letting us know.

I’d like to take a look at your Roon logs when this happens, can you please:

  • Turn Rasberry Pi WiFi on
  • Reproduce the issue
  • Note the exact local time + date of crash on iOS device
  • Turn Rasberry Pi WiFi off
  • Try to reproduce the issue
  • Note the exact local time + date the app opens properly and does not crash

Once I have these details, I can enable diagnostics mode to see if we can gather more info here, thanks!

Hi @noris,
of course I will do this!
I would be happy if the Pi works on wifi too…there are some rooms I just can reach with wifi…

I dont have to switch on enything for logging in roon? right?
I will do those steps as soon as possible…:wink:

Thanks for now!

1 Like

Hi @Andreas_Strobl,

No nothing needs to be switched on, do let me know once you have had a chance to run the test!

Hi @noris!

  • I just turned the Wifi on my RaspberryPi (running RoPieeeXL) on (3.Feb.2021, 17:50 Timezone Vienna)

  • After Rebooting of the Pi I will go to the room and open Roon on my iPhone (actual software, and plenty of free storage on my iPhone)…

  • So…trying to use roon on my iphone and ipad worked! I cant tell you how often I was able to reproduce this issu, but today I´m not…!

  • A week ago I encountered the iOS crashes when I switched on my guest-wifi… (without any wifi settings on the raspberry pi, because I set up a cable to the actual place)

  • I will now (17:59) switch off the wifi on the Pi and then turn on the guest-wifi…

  • Again…everythings fine…

Sorry, but I could not reproduce anything today! But I definitly could some days ago…I will have an eye on this!
And soon I will ad some more roon endpoints (with raspberry pi´s). Some of the new endpoints have to work via wifi, because no cable is possible there…lets see whats happening!

Anyway! I love roon!!
Thanks for now!

1 Like

Hi @Andreas_Strobl,

Thanks for looking into this further!
If you are able to get back into this state, please let me know!

Hi @noris !

In the meantime I had several situations where the iOS crashes happened again… each time several times in a row. With no chance to keep the app running longer than some seconds.
The first situation was just after the update of roon. A restart of my iPhone could fix it for some time.

But today the problem occured again…I did no restart of my iPhone yet and I let the app crash several times in a row, performing common actions in the app: searching for some music and starting a playback in my house…just to make some log-actaions for you, maybe you can find the issue…

Just now, between 10:20 to 10:26 (21.2.2021). Maybe you can have a look, whats the problem here!?

I did not change anything in the meantime. The only change was the update of roon.
I did not change any setting on my ropieee or any setting in my lan.

I am just about to try to move my core to my synology again, but I did not changes yet.


Same issue here. On my iPhone 11 Pro, the Roon iOS app will remain open for about 10 seconds at a time, then crash. My core is on a Roon ROCK server.

Hi All,

If you are still crashing on Roon 1.8 please let us know here:


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.