iPod Touch w/external Amp-Dac not recognized

For my portable headphone rig, I use the latest generation iPod Touch connected to a FiiO Q5S amp-dac via an MFi certified lightning to micro usb cable. This combination works great with Roon with the exception of the following “quirks,” or things that I just need help to better understand.

  1. When the iPod and Q5S are connected together both switched on and I open Roon, the iPod does not show up in my list of available Roon endpoints. If I unplug the Q5S, close the Roon app, then reopen the Roon app, the iPod shows up right away and can be selected. I can then plug the Q5S back in and begin listening.

  2. I have DSP enabled in my iPod settings to convert the sample rate from 44.1 to 88.2. I know that the iPod on its own cannot do 88.2 kHz, but when I go through the steps above to begin listening via the Q5S (which can do higher sample rates), Roon shows that DSP is enabled but no sample rate conversion is happening. This is confirmed in my signal path. If I then open the DSP settings and toggle the sample rate conversion button off and on, it begins to work and my signal path looks the way I want it. Here’s an example after completing both steps indicated above…

So my question is really how (or can) I open Roon with my iPod Touch and Q5S already connected together, have Roon recognize this endpoint, and begin playback using my chosen DSP settings without having to toggle DSP off and then on every time?

:sweat_smile:, if you read through all of that and can understand what I’m trying to say I thank you! Any insight is much appreciated.

I had similar problems connecting my Chord Mojo to an iPad/ iPhone when using a MFi certified lightning to micro usb cable . I resolved this by using the official Apple Lightning to USB Camera Adaptor.

Is this what you mean?

Because I have a Lightning to USB camera adapter and I don’t see how that would work exactly…

I also have a Chord Mojo, and this cable solved my issue of connecting it to my iPhone without needing an adapter… in case it’s helpful to you:


I don’t remember if I tried it with the iPod Touch and Q5S though, but I’ll give it a shot.

This is what I used (I now have the Poly):

Plug a USB to micro-USB into the adaptor.


Using one adapter to plug into another adapter may resolve the problem I’m having with Roon, but seemingly trades one issue for a different one (i.e. losing the ergonomics of the compact MFi certified cable, which works just fine between my two pieces of hardware). Not sure I want to go there.

I’m wondering if this problem is less cable related and more of a software issue within Roon?

Bump. @support

Hello @Riviera_Bluesman,

Roon’s iOS external DAC capabilities are tested exclusively using the Apple Camera Connection Kit. We have not seen reports of these issues when using the iOS Camera Connection Kit.

We would love to make this work, but we do not have the FiiO Q5S in-house to test with as they are not a Roon partner. In the interest of improving the behavior you are encountering we will reach out to them with hopes that a solution can be found. We suggest that you reach out to them as well to encourage the same.


1 Like

Thank you John. I will message FiiO as you suggested.

I understand that Roon cannot possibly be expected to work with every audio product out there, but in my mind if Roon IS compatible with Apple products (iPhone, iPad, iPod Touch) and I’m using a connection cable (which has received MFi certification from Apple) made specifically to work with these products, then the issue ultimately comes down to Roon not “seeing” or recognizing the fact that I have an external DAC-Amp connected to my endpoint.

What confuses me is if I open the Roon app first, select the iPod Touch as the audio zone, then connect the external DAC-Amp to the iPod Touch, Roon works fine - unless I have DSP settings enabled for the iPod Touch in which case I just need to toggle DSP off and back on for eveything to work as it should. This is a “workaround” I can live with, but what I was really wondering is if others had experienced the same, if there was already a known solution to resolve the issue, and if not can it be fixed via a change in Roon’s software.

I appreciate you following up with me.