Issue with DTS (5.1) wav file playback

@John_Smith —— Touching base with you here, in regard to your question about what device can function as a RoonBridge and perform multichannel playback.

Any NUC is going to be more than adequate to act as a RoonBridge, even for very demanding formats. The reason you are seeing the FLAC files being converted to 2.0 is because Airplay can only support 2 channels. Additionally, for DTS being transmitted over AirPlay, there is a chance that the Marantz sr 6011’s AirPlay implementation is not bit perfect OR the receiver itself does not support DTS over AirPlay.

I think it was a wise choice to get AirPlay out of the mix here and testing with the Vero4K. Are you still noticing the mentioned buzzing with this configuration in place and does restarting your client a few times return things to functioning order?

-Eric

@eric I set up roonbridge again on Vero4k device - with the latest updates… If roonbridge is set as 5.1. and if i check signal path its : source flac 96khz 24bit 6ch (5.1) -> osmc roon advanced transport -> output alsa. Im still getting buzz even while doing playback its part of the music… so its broken…

If i change setting to 7.1 the signal path its : source flac 96khz 24bit 6ch (5.1) ; * channel mapping 5.1 to 7.1 -> osmc -> output alsa… the playback works fine but why 7.1? and why such channel mapping is needed? If there is channel mapping my AVR is detecting input as PCM 7.1 and output it as Multi Ch 5.1

any view on that? thanks

hi,
what exactly does channel mapping from 5.1 to 7.1? does it somehow mask 2 channels or it splits 5.1 to 7.1? I spoke with vero4k architect and it can playbacks only 7.1 or 2.1 so for everything else they use channel masking.

So question is now what exactly does roon using channel mapping from 5.1 to 7.1?

thanks

@support,
Any update here?
thx

You expect support to answer overnight on Easter.

Hello @John_Smith,

Roon channel mapping is configurable by the user, so there’s no standard answer to give to your inquiry. Please check out our Knowledge Base article for more information, it explains the logic involved in multichannel mixing well as our recommended default settings

https://kb.roonlabs.com/Multichannel

-John

@john i already checked but all what i need is to convert original source as 5.1 to 7.1 where 2x channels will be filled with no signal. And thats not clear to me if it works like that or somehow else.

Hello @John_Smith,

I believe the “channel mapping only” option will do what you are describing.

-John

Hi @john
Yeah, thats what I choose “channel mapping” but I wanted to test it somehow.

Hi, are you not able to test this using a multichannel channel ident test disk / test files?

EDIT: I’ve just re-read this topic, if you’re unable to test because your Roon trial has expired… if you ask Roonlabs I’m sure they would grant you another trial.

@Carl do you have ident test disk/files?

I just downloaded all these files from https://github.com/sfiera/flac-test-files

The results are following: (my avr has 5.1 speakers); while doing playback of these files via roon each uses Channel mapping to 7.1, only surround71 is playbacked without mapping.

stereo.flac - no sound - no idea why?
center. -> left/right ok, fc is playbacking via sub instead of center ie ISSUE
quad. -> all ok
surround 50 -> fl/fr/ rl/rr OK, FC (center) goes to sub ie ISSUE
surround 51 -> FL/ FR ok, FC -> goes to sub ie ISSUE, LFE -> goes via center ie ISSUE , RL/RR are OK
surround7.1 -> FL/FR, FC same issue as 51, LFE same issue as 5.1, RL/RR OK, SL/SR ok but goes via RL/RR

Then i made another test so i playback all these files via Kodi which is also installed on the vero4k which is acting as roon bridge and results are as follow: all the tests passed OKAY

Now question is … where is the problem :slight_smile: is the channel mapping in roon broken, or is the issue on vero4k where roon-bridge app is not able to output correctly via hdmi?

I am also listening some 5.1 flacs and i think it works fine … so im totally confused…

1 Like

Hi @John_Smith — After seeing your most recent post I decided to search the Vero4K community site to what other Vero4K users have reported when making us of multichannel content with the device. Please see below.

[Testing] Improved multi-channel PCM for Vero4K

I believe the link above to be the most up to date and relevant but I came the following as well:

Multichannel audio incorrectly mapped

Multichannel (non-passthrough) surround sound stopped working after June update

Multichannel PCM output over HDMI

-Eric

Hi @John_Smith,

I have the exact same issue:

  • playing 5.1 or 7.1 files from OSMC works fine.
  • playing the same files via Roon Bridge installed on Vero4K “almost” works: LFE and center channels are swapped.

I am running:

  • Linux Vero4Kplus 3.14.29-121-osmc
  • RoonBridge 100000164, 1.0 (build 164) stable

Ben.

I tried to map the speakers by creating an Alsa route:
In /etc/asound.conf, in order to switch LFE and FC I added:

pcm.hdmi2 {
type route
slave.pcm “plughw:0,0”
ttable.0.0 1
ttable.1.1 1
ttable.2.3 1
ttable.3.2 1
ttable.4.4 1
ttable.5.5 1
ttable.6.6 1
ttable.7.7 1
}

Then, in order to make RAATS use that, I manually updated the settings file /var/roon/RAATServer/Settings/device_xxxxxxxxxxxxxxx.json by updating the device variable to hdmi2:

{“external_config”: {“max_bits_per_sample”: 24, “max_sample_rate_multiplier”: 4}, “output”: {“type”: “alsa”, “force_max_volume”: false, “dsd_mode”: “none”, “device”: “hdmi2”, “name”: “AML-M8AUDIO”}, “unique_id”: “xxxxxxxxxxxxxxxx”, “volume”: null}

But this cannot work:

10/11 14:59:49 Trace: [RAAT::AML-M8AUDIO] [ALSA] [hdmi2] Initialized with 2 periods with 2048 frames/period and 4096 frames/buffer
10/11 14:59:49 Error: [RAAT::AML-M8AUDIO] error in snd_pcm_set_chmap: No such device or address (-6)

So I guess there is no workaround here unless Roon allows us to manually map the channels.
Deal breaker. :frowning:

Ben.

I’m listening to a DTS-CD ripped to Roon and played through a Marantz AV8802a, right now as I type this. It works perfectly. It may appear complicated, but actually isn’t. There is one key thing to remember: as far as Roon is concerned, your DTS track is a stereo (2 channel) track. Period. Don’t do any processing at all in Roon. No DSP. No volume adjustment. No channel mapping. Nothing at all!

You can only make adjustments in your pre-pro/receiver/etc after the DTS has been decoded.

I suggest the following steps to get it working. I’m assuming you’re starting with a DTS-CD; if you have a DTS track ripped from a DVD, the steps will be the same, but it will be 48KHz/16 bit/2 channel (DVD) instead of 44.1KHz/16 bit/2 ch (CD).

  1. Turn the volume down to a low but audible level on your receiver/pre-pro for safety’s sake.

  2. Make sure you can play a ripped regular CD through Roon and have the purple indicator denoting bit-perfect playback to the right of the currently playing track lit. If this is green instead of purple, it won’t work (playing over AirPlay won’t work, for example). Do NOT continue until you have a purple indicator; it will not work. [NB: If you are trying to play a ripped DVD DTS audio track, do this but with a 2 channel, 48 KHz audio track instead of a track ripped from CD. Again you will need a purple indicator, or it won’t work.]

  3. Making zero changes to your configuration from success at step (2), play your DTS file. Your receiver/pre-pro should switch into DTS mode, and play what you’re expecting. Now turn the volume back up to your desired listening level and enjoy.

The key step is getting the original bits from the DTS-CD to the receiver/pre-pro without modification. I mean with any modification at all: if applicable, you want to set Roon to exclusive mode for your audio output device, and if integer mode applies, it’s a good idea to use that as well.

I’m currently listening via a RasberryPi running RoonBridge via Ropieee feeding a SP/DIF input on my pre-pro. I don’t have HDMI hooked up at the moment, but would recommend configuring your HDMI output in Roon as a 2.0 configuration to get started. If that works, you can play with other configurations; you probably want the play stereo as 2 channel (I forget the exact name of the option, and it’s dinner time) option enabled, but try both ways and see.

Good luck!

Let me follow up: I’ve now configured HDMI, and it’s all working for me. Fixed volume, and either a 2.0 configuration or a 5.1 configuration with “Send stereo/mono as 5.1” set to No.

Remember, Roon treats DTS as 2ch PCM white noise, and it needs to pass through with absolutely no changes being made to it, so the receiver/pre-pro can recognize it as DTSand decode it back into its 5.1 glory.

Good luck!

I am getting a purple indicator for Alan Parson Project “Blue Blue Sky” DTS and it is 2 channel 44.1KHz. I have this playing through my unRaid server using roonserver docker to a Trinnov Altitude32 9.1.6 system. I am able to play this as DTS 5.1 through jriver, however, all I get is hiss through Roon. Any suggestions? I have read through a number of threads and it seems to be hit and miss for many. Output shows a purple indicator as well.

How is your Trinnov attached to your Roon core? Can you try a different connection? If all else fails, I’d recommend a separate Roon endpoint connecting to the Trinnov. If you’re tech savvy, this can be as inexpensive as a Raspberry Pi, a SPDIF “hat” if needed, and Ropieee software to turn the Pi into a Roon endpoint; otherwise there are commercial products starting in the hundreds of dollars that are certified Roon Ready.

As it stands now, one of two things is true: 1) the audio is getting corrupted after it leaves Roon (I know nothing about unRaid other than it exists), or 2) your Trinnov doesn’t decode DTS on the input you’re playing Roon through. DTS CD is a fairly obscure format, and I don’t think Roon officially supports it, so it might not be part of Roon Ready testing if you’re connected to the Trinnov via Ethernet. (By sheer dumb luck, it’s possible the DLNA client works via JRiver.) I find computer implementations of HDMI to be hit or miss, so I’d recommend SPDIF (either coax or Toslink should be fine) that looks to the pre-pro like you plugged in an old DVD player. There’s no reason that DTS CD over USB (if the Trinnov has an USB input) shouldn’t work if you have a bit perfect path, but it’s non-standard, so less likely to have been tested. USB to SPDIF converters should be bit perfect, but you won’t know without testing…

If you have the right equipment for DoP and/or MQA, those are two other formats that rely on a bit perfect stereo PCM path to function as intended.

Good luck!

I turned on Volume Leveling recently and that killed DTS FLAC playback for me. Make sure that and any DSP is off too !

Make sure your end-point is receiving a 2.0 Channel input. If this is 5.1 channel or higher it will not work. On a Macmini you’ll need to turn exclusive mode off and force 2.0, 44 khz within the audio device setup program in Macos.
Guido.