Issue with FIIo M11s

HI my FIIO M11 s can’t connected with Roon Arc while the Roon app works flawlessly. My iPhone and iPad are connected to Roon Arc without any problems so I don’t think of a network issue . The M11s is under Android 10. Thanks for your advices

1 Like

Is the Fiio a Roon aprooved device? I know my Shanling M6 Ultra is in the middle of the process, these are Shanling’s words.

Hit Fiio up on Facebook, they will let you know for sure.


No they are not, although rumours the latest M11 is going through certification but that’s not for ARC only to be Roon Ready or Roon Tested. There are no ARC approved devices just needs Android 8 or higher.

1 Like

i send a mail to Fiio for that issue, for them everything should be working…
what’s weir , at the beginnig Roon arc was workin’ fine but after one uptade the core wasn’t find anymore. have a nice day Ryan

Thanks for your explanation.

Was this resolved? I’m curious about this dap. I read it doesn’t have the same sample rate restrictions as other android devices. Is it possible to achieve bit perfect using as a Roon endpoint?

I do not know if this had been fixed on Fiio DAPs, but it will be fixed on Shanling DAPs.

No not yet. Roons resampling is built into the remote apps Android output so can’t be bypassed, you need to be Roon Ready to achieve it. Only some A&K daps currently hold that status.

i can use that Dap with the roon app but not with roon arc

I can use the M11S with Roon Arc. Just got it yesterday so don’t know if there was an issue that Fiio resolved since you last posted a couple of months ago.

I do have an issue of my own though that hopefully somebody might be able to help with. In the Fiio music app there is an option to add a media server to play local files from that server over the network. I was hoping to add my ROCK as media server but it’s asking for a username and password. I did enter my Roon details not expecting it to work, and it surely didn’t. Any clues as to what is needed here?


1 Like

guest is username and password for accessing Roons storage.

Why are you using Fiio app it’s Roon Ready with latest firmware so becomes a Roon endpoint you can play to bit perfect. Been using my M11 Plus all week as one it’s fab.

1 Like

Couldn’t get to work using guest as username and password, just got a failure message.

Just though it’d be a useful backup scenario to have in case of some unforeseen circumstance with Roon/Roon Arc.

I just tried no dice. Will be some samba version issue no doubt.

Can connect via smb1 using UAPP app so yeah it’s likely version and you normally have to also add the shared folder which in this case is data, but Fiio app doesn’t have that option.

You’ve kinda lost me a bit with your last post (not hard lol). Are you saying that while using UAPP you can see local music files attached to ROCK server? Sorry if I’ve got wrong end of the stick, and could you explain how you got it to work with UAPP, thanks.

Yes just added it in the network section using SMBv1 and you add data as the share. You can’t use it in any other app though this is just for UAPP.

SMB (samba)comes in different versions and it seems that Rock only allows connection from Android via version 1. Also you have to enter in the shared folder or it won’t connect in the case of Rock it’s data as that’s the folder exposed via its smb share. The fiio app doesn’t have the option to add this and I wonder if that’s the issue or it’s just using a version of smb Rock doesn’t like.

1 Like

Nice one, thanks that’s working perfectly.

1 Like

Getting back to Roon with the M11S. I tried it this morning in Roon Ready mode and it’s a bit flaky for me. Sometimes only get about a minute or two of playback and the song stops playing. It’s not buffering or anything, and i have to hit the play button again to start the song again. I don’t think I’ve had a full song play before going through the same scenario again. No idea if this is a wifi or network issue, but I’d be surprised if it was because it’s only with Roon this happens. Qobuz or Tidal on their own players are fine, as is Qobuz or Tidal playback with UAPP.
Have you experienced anything like this with Roon and your M11 Pro?

No rock solid, but I have a very solid wifi system. Because Qobuz or Tidal work doesnt mean Roon will be the same, its more demanding on any network as its full PCM not flac which are smaller files so if your borderline it could push it over. That aside I have found it to be forgiving even when it drops to 2.4ghz but its mainly on 5ghz. Not had one playback glitch and I am roaming over the whole house. Give it a reboot. I have only really been using Roon on it as no need for anything else.

Is there any other music players running in the background. I ask as they might be taking control of the playback. Its easy to press a button and they will take control of the audio. Also if you have Roon remote active on it, make sure you disable the apps own audio zone as that can cause some issues as it conflicts with the native Roon Ready output I have found but when disabled works as it should.

Mind if I ask @kevin_wynne1 and @CrystalGipsy if your WiFi setups are single or multi access points?

I have a full Unifi system including router, switches and access points all of which are hard wired. There are 3 Access points covering my house one upstairs one downstairs and one in the outside office (just retired one extra one downstairs as it was overkill as I had 4).

I just tested walking from my office to the house to get a cup of tea with M11 plugged into my ears. it didn’t drop a beat. The office is at the bottom of the garden not a huge distance but would be out of range if it wasn’t for the AP in the office. Same goes inside it seamlessly moves around the AP’s inside with out any issues.

Overall I have about 20 wireless clients in the house and another 10-12 wired.