Issue with Roon ARC connection

Roon Core Machine

NUC Intel
Roon version 2.0 (build 1128)

Networking Gear & Setup Details

Virgin Media (UK), with Hub 3.0 in Router Mode, and has UPnP disabled
Hub 3.0 is connected to Asus ZenWiFi AX. This has UPnP enabled, and have setup Port Forwarding rule for Roon Core (ROCK).
Netgear GS308 is connected to Asus
Wired connection from GS308 to to Netgear GS316 in other room
NUC Intel (Roon Core) connected to Netgear GS316
NAS drive containing music connected to Netgear GS316
Other devices connected to GS316
There is also another Asus ZenWifi that connects to the main Asus ZenWifi - this increases WiFi coverage

Connected Audio Devices

Sonos Play 5 * 2
Sonos Play 1 * 2
Sonos Connect Amp

Number of Tracks in Library

Description of Issue

Setting up Roon ARC is not working.
In my iMac when I launch the Roon Application and go to Settings → Roon ARC, it says “Roon ARC was unable to securely access your Roon Core”.

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“...“,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:”
..*.*”,“found_upnp”:true,“error”:“doaction request return statuscode: UnknownError”}

Note I have hidden the IP address’s do not want to make that public.
I tried disabling the firewall’s in both Hub 3.0 and Asus router - did not work, so enabled them again.
I also tried setting up DDNS on the Asus router, that also did not help.

I have been able to solve the above problem by setting up a port forwarding rule on the virgin media hub to forward onto the asus router, as suggested in one of the posts from this post

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.