Issues connecting to Roon ARC

Roon Core Machine

Enhetsnavn Stians-PC
Prosessor 11th Gen Intel(R) Core™ i9-11900K @ 3.50GHz 3.50 GHz
Installert RAM 32,0 GB (31,8 GB brukbar)
Enhets-ID 8EFEF404-9838-41C6-8C70-DEFB40EC5478
Produkt-ID 00330-80000-00000-AA760
Systemtype 64-biters operativsystem, x64-basert prosessor
Penn og berøring Ingen penne- og berøringsinndata er tilgjengelige for denne skjermen
Versjon Windows 11 Pro
Versjon 22H2
Installert den ‎30.‎11.‎2022
Operativsystembygg 22621.2134
Opplevelse Windows Feature Experience Pack 1000.22659.1000.0

Networking Gear & Setup Details

  1. Who is your internet service provider?
    Viken Fiber

  2. Please list the make and model of your modem and router?
    Modem: Zyxel VMG8825-B50B
    Router: Netgear Orbi Router RBR50v2

  3. Do you have any additional network hardware, like additional routers or managed switches?
    1 satellite for Orbi

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?
    Not that I know of.

Connected Audio Devices

Topping L30 USB DAC
Topping E30 USB amp

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},
“status”: “status”: MultipleNatFound
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}

Welcome to the community.

Your are dealing with a multiple NAT issue. This means you have your own router behind the router provided by your ISP, which in your case is the Zyxel I guess.

You should try to enable bridge mode on your ISP’s router.

So I tried bridge mode, and it kind of worked for a day or two, but just now my internet suddenly stopped working, and I found out my Netgear Orbi router dont support bridge mode.
Is there another way to get ARK to work, or do I have to change my router?

Assuming that the Zyxel is connected to the internet and the Orbi is connected to the Zyxel, bridge mode must be enabled on the Zyxel, not the Orbi. After enabling bridge mode I would recommend a reboot of the Orbi.

The other alternative is manually defining port forwarding rules on the Zyxel and the Orbi

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.