Issues with importing music from Synology NAS

I just installed Roon Server on my Synology DS1815+ today. I’m using my MAC OSX as Roon Remote. After adding my Watched folder, which points to the Music folder on my NAS, my music files don’t seem to be importing. I think I may have done something wrong here but I don’t know what… under Settings, Storage, the path to my NAS says Connected and Watching for new files in real time… what does this mean? I have about 3TB in music stored on my NAS. does it take some time to get the import going or something? thank you very much for helping a newbie out :slight_smile:

Can you post a screenshot of your Settings > Storage window?

Hi Ganesan,

Welcome to the world of Roon, enjoy.

Where are the music files stored on the NAS?
Can you post some screen shots from Roon’s Settings --> Storage showing how you have setup the watched folder.

The thing to note is that as the Roon Core is running on the NAS itself the path (for the Core) to the audio files is a local path not a shared network path.

thank you for offering to help. i’ve uploaded the screenshot as requested. in case i’ve put in the path wrongly - which i suspect i have - please guide me on what to do next.

If you use RoonServer on a Synology, you need to use local path.
Click on “Add local folder” when you are in the “Add folder” window.
The path would most likely be

make sure everything is correct regarding case-sensitivity.
If I remember correctly the default Music folder on Synology is lower case
Then it would be

Also make sure you did not accidentally set your macOS Roon to be a server as well.
To rule that out you can simply quit Roon on macOS and delete the Roon folder in your user library.
To access your user’s library (it’s hidden by default) you can use the “Go to” section in the menu bar while holding the option/alt key:

EDIT: I read in your screenshot, that “Synology” is your core (next to settings). So I guess you are connected to it. I’ll keep the step in here as it might be helpful for others with a similar issue. :slight_smile:


thank you very much Christopher and Carl for pointing out that I need to add this as Local Path instead of Network Path. I am now in the process of importing my library :slight_smile: it’s past midnight here in Singapore so in the morning, I’ll config my Sonore MicroRendu next! Have a good day ahead of you.


are there any circumstances where not all my albums will be imported? for example, Audirvana shows there are 4055 albums in my collection currently but Roon only shows 3870 albums.

Roon will combine multiple editions of an album (say you have the CD and a high res version) and it counts multi-disc and box sets as one album. Both of these features will decrease your total album count in the albums view.

To see where multiple versions have been combined you can click on Focus in the album view, scroll the focus box all the way to the right, tap inspector, then tap hidden. This will show you everything with duplicates broken out.

Unfortunately there’s no way to get it to show you a total disc count so box sets may still be lowering your total.

You can also export your albums list to an excel spreadsheet (only works from a computer). From the albums view select all (control-A / command-A (Windows/Mac)) and select export from the three dots menu in the upper left.

Roon will skip certain blacklisted folders and files based on names or formats. There’s a very good description in the FAQ:’t_showing_up_in_Roon