Issues with Roon’s tagging for classical music

I am just starting to use Roon, with a NUC running ROCK as Core, and several devices to play through and an iPad.
I have a library of around 9000 records, more than half being classical music. They come from my CDs which I ripped, or from records downloaded from Qobuz or B&W.
I paid high attention to the tagging which I reformatted strictly with one syntax, and securing as well that artist and artist album are equal (I went through using many streamers like Linn, Sonos, Bluesound, TotalDac, … and multiple apps).
Now Roon wants to reinject the initial tags of the album which is a big issue as with classical music you can find anything (eg name starting with composer, or maestro, or main artist, …).
There is an option to favor the tagging attached to the file.
However, for a proportion of the records, Roon doesn’t apply that option but continues to apply the taggings of its own findings based on public libraries. It is a bit frustrating as I can then find an album anywhere in the list (eg Abbado, Mozart, or main singer …). Which was exactly why I retagged them all…
How to correct? Is it a well known bug?

1 Like

How did you configure your import settings? What tags specifically are you seeing that Roon overrides with its own info? In my experience, Roon has always respected the file tags for Album title and Composer, although artists (performers) can be a bit hit or miss and may require some manual tweaking after importing.

To give an example. I bought the full collection of Claudio Abbabo’s symphony on Deutsche Gramophone via Quobuz. I retagged everything to split between Composers. I created for example one « record » for each Mozart’s symphony, tagged as follows: composer = Wolfgand Amadeus Mozart, Artist = Mozart WA [Abbado, Mozart Orch], Title = Mozart WA: Symphonie n29 [Abbado, Mozart Orch]{Qobuz}.
Now this has been overriten by Roon, and the artist is now Claudio Abbado, and the title of the record is: Claudio Abbado, the Symphony Edition I (…). Which is the tagging of the source at Qobuz which I retagged…
And that even if in Roon’s parameters, I clearly stated that I wanted to use the metadata of the files when it comes to title and artist.
This issue comes with some albums. In addition, in the above example, Roon also merged 3 albums which I have decided to split in my library (In that case I had chosen to tag one album per symphony when Roon regrouped 3 of them).

Hi @FredYves,

May I ask that you navigate to Settings > Library > Import Settings and share a screenshot? Here there will be preference settings for what metadata is used, as seen below:

Can you also provide some screenshots for the example you mentioned above so we can take a closer look at that album? Please include screenshots of the main album page as well as the Metadata Preference and Edit Album tabs of Edit for the album.


A screenshot of the metadata.
I clearly don’t want to use the selection you have proposed because it would then be impossible to easily an album just by alphabetic order.
You have to have in mind that I applyied a unique syntax one by one to 4000 albums.

Sorry, I have some issues with the copy - paste … Previous picture is what is shown in Roon with the Symphony Edition I, by Claudio Abbado. So info is shown as from the source from Qobuz.

Which is not what I wanted, as I’ve set the parameters / metadata as follows

The structure I expect is the one which I can see for example in Bluesound’s app

Copying again the upper side of the screen on Roon about the same

Same issue for another Album, Abbado again (I like that conductor ; -), in an original album encompassing opus from Mahler and Debussy.
In Roon it appears like that, with artist = Claudio Abbado

When again, I on purpose retagged it totally as follows (also from Bluesound app). You can see that I retagged artist = Debussy C [Abbado,Lucerne]
In addition, I keep the origin of the data in the name of the album, eg {Qobuz} when coming from Qobuz, and even {Qobuz MA} when resolution is above CD blue book (I do that as not all streamers read these files - eg not the Sonos)

I thank you in advance for your help.
I was informed in the forum that Roon was not ideal for Classical music, but I thought I would be immune as I strictly retagged all my files with one syntax for Classical. And it has proven to be solid so far whatever the app I have used (Linn, Lumin, Sonos, Bluesound, ipeng, …).
It is a pity, because otherwise the app is very nice and allows me to manage with one interface very different devices + the navigation across public sources.
Best regards

Its not only “not ideal” ist is totally unusuable as far as I can tell after playing with it for couple of weeks.

Apparently Version 1.7 introduced “Artificial Intelligence”. It’s certainly very much Artificial. But has nothing to do with Intelligent.

I am following the best practice tagging here.

But in Abbado Album of Bach Brandenburg Concertos it picks up my tagging for 5 Albums but then decides to use Roon database for the last 3 tracks. The settings are the same for the entire Album, ie use my Tags not Roon! This is just one example. It messes up most of my 6000 Albums.

I am using so far MinimServer and LUMIN App. I guess I move back. Wasted 120 USD. That Sucks. But there are worse things in life.

Which album is that? If it is the 2CD set with Orchestra Mozart, roon shouldn’t be splitting the album into 5/6 albums. That would point to roon having problems interpreting local tags. Do you have a screenshot? It’s possible a few simple fixes might improve things. Roon certainly has issues with Classical libraries but it is not normally a complete disaster.

Hi Tony,

yep, its the 2CD Album. Unfortunately I did not take a screenprint and have now corrected that concerto title manually in Roon. But I am not going thru the same chore for my 6000+ albums.

I will stick with Minimserver / LUMIN for now until some very fundamental changes in functionality are being implemented in Roon, mainly having an option called “Strictly observe File Tags” (or similar) for Album names, Titles, Artists, Soloists etc.

I told Roon to use file Tags during import. But it just does not observe that instruction!

The only Item Roon already handles correctly based on user tags is Genre. It should follow the same rules (if the user wishes) for the Tags mentioned above. For all the other ones (Executive Producer, Release Date, 2nd fiddler, booklet editor, artist photographer and whatever other irrelevant stuff) I dont really care about and Roon can fill those up as it sees fit.

Many thanks again for your help.