John Barbirolli, Hallé Orchestra, Sibelius

Apparently this Sibelius symphonies cycle is one of the best so I looked it up on Qobuz, added to the library. A multi-part work is shown, but the symphonies are not identified as the work that they are and linked to all the other versions in my library/tidal/qobuz etc.
This happens for all 7 albums with the 7 symphonies. Here’s the first in the list, link at Qobuz:
Sir John Barbirolli - “Sibelius: Symphony No. 1”

How can this be fixed? Is this something you guys are doing or could we?13

i tried to mimic your steps but couldn’t finish the first step. That album doesn’t seem to exist in my version of Qobuz.

It’s also on tidal.

@joel could you please work your magic once again? or let me know how I can fix this on my own?

@Radu_Popescu The problem here is that the tracks don’t have any composer credits (we already have a plan to sort this out, but it will take a while).

If you have all of these Sibelius compositions in your library already, adding a Sibelius composer credit to all of the tracks should, hopefully, do what you want.

I can confirm that works.

But I find this a lot. Not every time but a lot. Has Qobuz got no composer credits a all? I notice that on Qobuz when I do a search of a composer it doesn’t return a list of similar composers but a list of similar ‘artists’. I also notice there is no grouping of multi-part works. I am so used to rubbish meta-data that at first I just thought that was all it was and just filled in the gaps manually myself. But this is looking systemic. Is that thee case

Hi @joel!

That worked for some but not all the albums; I’m attaching photos of one that worked, and one that didn’t.

Tony, the Qobuz Osmo Vanska with the Minnesota Orchestra cycle had proper credits for all the discs.

Edit your track title for the 4th track to include a space between “Op.” and “105”.

What’s happening is that the space is interfering with our extraction of a common “stem”, so the opus number is not in the composition title. No opus or catalog number is why it’s not working.

Thank you again @joel, that worked for both albums! Much appreciated.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.