Just setup ROCK and ARC won't work

Roon Core Machine

Roon CORE running ROCK (latest version)
Intel NUC11PAHi7
11th Generation Intel Core i7-1165G7 @ 2.8 GHz – 4.8 GHz Turbo, 4 core, 8 thread, 12MB Cache
28W Intel Iris X Graphics, up to 1.3 GHz, 96 EU units
256GB PCIe Solid State Drive (SSD)
Ethernet connected

Networking Gear & Setup Details

Linksys WiFi 6e Triband Router MR7500
Three Linksys Atlases (MX8503)

Connected Audio Devices

Topping DX3 Pro connected to the Core.

Number of Tracks in Library

9500 tracks.

Description of Issue

Just setup ROCK on a new NUC. Everything works great except for ARC. That doesn’t work at all.

I get this:

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“47.aaa.bbb.ccc”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“>\n<s:Body>\n<s:Fault>\ns:Client\nUPnPError\n\n<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">\n501\nPAL_UPNP_SOAP_E_ACTION_FAILED\n\n\n</s:Fault>\n</s:Body>\n</s:Envelope>\n”}

I’ve setup my router like the guide says to, but ARC still doesn’t work.


Hi Shane

I see your Core IP is, typically the gateway IP.

Can you access your core with that IP from a browser? Or do you access your router?

Also, could you confirm how your Linksys devices are all connected.


I can access the ROCK core from a browser. I get this.

All good!

I’m not sure how to describe how my network stuff is hooked up. The router is a Linksys WiFi 6e Triband Router MR7500. The ROCK Core is wired by ethernet to that router, but with a Linksys gigabit switch in between (I have other HTPC devices attached to it). In addition to the router, there are three Linksys Atlases (MX8503) working as a single unit - Linksys did that so that the Atlases and the router would work as one network (or something to that effect).

In the Linksys router sertings, have you checked the UPnP settings to ensure they’re enabled correctly or have you manually setup port forwarding. Screenshots may help

The router was already set this way:

I’ve tried to setup a manual port via the web admin and also through the Linksys phone app, but that hasn’t worked. I think I’m missing something obvious, but I have no idea what.

The port forwarding bit of my router looks like this (after I deleted the rules)

There’s also this, though I don’t know if it’s relevant at all.

Thanks for the help.

Try turning off UPnP.

On port forwarding

Set internal and external ports to that in Roon on the Arc tab.
Set the IP as per the same on the Arc tab.
Then save

What happens now?

1 Like


I guess it was turning off UPnP and leaving it off. I hadn’t thought to do that.

Thank you, kind Sir.


Glad it’s sorted.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.