Just upgraded and no longer connects using 5Ghz wireless

Hi @spockfish
Just updated this morning all my Ropieee endpoints and they now no longer will connect via 5ghz wireless. They have been running fine for 2 years and where prior to the update this morning but now refuse to connect. Rebooted several times. What can I do?

Feedback for pi4


For Pi3b+


Looks to be support for certain channels has changed. I have used one particular DFS channel for the ap these connect to and it’s bit been an issue. I swapped it to a non DFS channel and they connected . I use the DFS as they are less crowded in my area. No radar active and other devices where still working on it. So this looks to be a regression bug of some kind.

1 Like

I think this might be a regulatory thingie. There’s nothing wrong from your logs. It also states that DFS is enabled. What channel is it that you were using?

I was on channel 120 which has worked flawlessly for years.

Weird. You could try the beta channel. In looking for your problem I updated the regulatory database over there. Maybe that makes a difference.

Did you just update that? As I tried beta after this stopped working and it was the same.

I updated that half an hour ago.

1 Like

Will try it out.

My Ropieee 4.017 endpoint for PI4 working only with 2.4 ghz wifi network. Before upgrade all work fine with 5ghz wifi. Please fix that.

My Ropieee 4.017 stopped working in the last couple of days. I last used it Saturday and this morning (Tuesday) I can’t use it. I have connected it via ethernet and it is working again so presumably I am having the same problem with 5GHz wifi. Unfortunately I don’t run a 2.4 GHz network in my house to test if that would work. But ethernet does and wifi no longer does. Oddly I have another Ropieee 4.017 endpoint also connected via wifi which seems to connect and work fine.

What type of Pi do you use?

They are all Raspberry Pi 4 Model B Rev 1.2

On my lunch break I moved the one that wasn’t working from my office to my living room next to the one that was still working at it works no problem there. So it seems like it won’t connect to my WiFi mesh repeater. Very odd since it has worked for a year or more without problems through the mesh repeater, and also my other devices in my office - phones, tablet, laptop - all continue to connect without a problem.
It connected fine via ethernet through the cable that usually connects to my mesh repeater.

Not sure if there is anything you want me to do with regards to trouble shooting/submitting logs to better understand the problem?

Hi Harry

I have connected via ethernet and sent some feedback - 1a399c9b98a2b7ee - I can no longer connect to my wireless access point since 4.017. The access point still works for all other devices in my house and previously worked with Ropieee

Encounter same issues here, 2 of my RopieeeXL endpoints (RPi4, RPi3+) lost 5G WiFi connections after the auto upgrade. I have to plugin a Ethernet cable and switch both endpoint to my already congested 2.4G WiFi.

Other Ropieee XL endpoints still on 4.002 was still able able to connect to the 5G WiFi network.

1 Like

@spockfish I’m having the same problem on 4.019 on a Pi 4 Model B Rev 1.4. I’ve tried stable, beta and test and none of them connect to the 5ghz network running on channel 128. I’m running an Eero mesh network and the timezones are the same on the Eero and Ropieee.

Is this a wireless channel issue? Is there a fix for this or can I revert to an older firmware? Thanks for all your efforts here.

The pi and especially with Ropieee is a bit odd with the a lot of the higher DFS channels. It just stopped working for me some time ago on these so went back down till I found one that worked. Another thing is they often stop working if there is radar detected in the area.

Thanks! Unfortunately, as far as I can tell, Eero doesn’t allow you to change wireless channels.