Kef LS50 my 5G network is not seen

Hi there,

My set-up is as follows;

iMac 2013 (Late 2013)
2.7 GHz Intel Core i5
16BG 1600 MHz DDR3

Roon Version 1.6 (build 401) stable (64bit), using Tidal.

Modem ZTE ZXHN H268A

KEF LS50 Wireless firmware V2.1.0

The issue I’m having is when I set-up the KEFs through the KEF Steam app on my iPhone is not being able to see the 5G network, only the 2.4G network is available.

The modem is 3.5 metres away from the master speaker, I’ve factory reset the KEFs several times but haven’t had any success.

I’m not really that technical any help would be much appreciated.


I think it’s a channel issue.

You should change the channel of 5G in your router.

1 Like

I can confirm this solved the issue, thank you very much Marco!

1 Like

Hi mate, please advise the recommended settings to get this working. I’m facing a similar issue, my speakers won’t detect 5ghz network. What should I chose in channel and channel width. Thanks in advance

I had the exact same issue a couple of weeks ago and can confirm changing the channel solved the issue. As I understand it, choosing a good channel depends on the circumstances in your network. I downloaded an app called WiFi Analyzer on my phone and used it to get a clearer picture of what channel would be the best to use. I’m no network expert, but it was all very straight forward. After changing to a better working channel in my router my speakers were able to detect my 5GHz network.

Thanks for your response mate. I saw Kef support page and sort of figured out. My issue at the moment is, my speakers are not playing hi-res files anything above 94khz it starts stuttering.