Kef LS50W - can't play hi-res above 96kHz

It was on the KEF side and I was never able to solve it so I returned the speakers. Other people have reported the same issue so I believe KEF has an issue supporting resolution above 96khz. Most people don’t have a lot of music above 96kHz so it’s probably only an issue for a minority of KEF’s users. But I think KEF should stop advertising that resolution if they don’t support it well.

1 Like

This can only be an issue with some units.

My LS50W support 192/24 over wi-fi or wired Ethernet. I upsample everything to 192/24 via Roon and I have some native 192/24 content as well, all of which play without issue.

For me, I cannot play my 24/192 content from my NAS, nor from another location on my network. I have swapped out every network component and cable to no avail. However, I can stream 24/192 tracks from Tidal without issue.

24/192 tracks in Tidal are inherently MQA.
As such… only the first unfold is performed by Roon when playing to LS50W. So… you are only streaming 24/96 across your network in this instance. Unless you’re performing up-sampling in Roon DSP.

Hi @Damon_Haley

I have exactly the same problem - 192/24 files won’t play on the LS50s, I’ve had to down sample to 96Khz. Did you resolve the problem or replace your speakers?

I’ve had it confirmed by KEF through the dealer that the 96KHz ceiling is a known issue. I’m in the process of swapping mine out. Apparently numbers affected are low, they cited ‘two’ but I suspect they are just trying to protect their reputation based on the numbers reported on this forum alone.

I have had my LS50W since they first came out. I have some of the earliest serial numbers according to KEF. This thread got me wondering if I have a 24/192 problem. I was happy to discover that I do not. I am right now listening to a 24/192 file and it sounds great. Whew!!


Don’t the the LS50Ws down sample to 96/24 internally anyway? I thought I has seen his somewhere but I can’t find it. The LSX does this for data between speakers when connected by ethernet and to 48/24 if they are connected via wireless.

This is from the KEF website:

Up to 192kHz (USB Type B)
Up to 96kHz (TOSLINK Optical)
Depending on source resolution

I use mine via Ethernet. There is no mention of what they do on a wired Ethernet connection but as you can see they are capable of doing 192kHz. I assume they do that on Ethernet as well. Just wish the web site was not so vague.

I decided to exchange mine and received the replacement today. Pleased to say the issue is not present on the new pair and 192 kHz files play perfectly. I let KEF know this and hopefully this helps others who have the problem.

Yes that’s the input specification ie what files they can receive. I am talking about how they communicate internally between speakers. The LSX certainly can receive 192/24 files but down samples to 96/24 for communicating to the other speaker (see the article linked above) I thought I had seen something saying the same for the LS50W but I maybe wrong on that front.

The LS50W and the LSX are two completely different speakers. The only reason people compare them is because they are both made by KEF. You can’t compare the two because the DAC is different. It’s also half as much money. The spec you referred to as the input spec is the output spec.

I have the same issue playing 192/24 files. The problem always occurs when streaming 192 from Qobuz and sometimes occurs when streaming 192/24 from the internal storage on my Nucleus…sometimes not. I contacted KEF and recommended 5khz WiFi. Mine is 2.4. Nothing in their documentation specifies this. I suspect the issue is more than they are letting on. My speakers are still within a 60 day return period. Do you think it would be a good idea to try another pair?

Perhaps you could try a 2.4/5.0 router within the 60 day return policy for the speakers.

I personally, would exchange them. My new pair will play 192kHz over 2.4/5 and ethernet.

Mine play 192/24 over 2.4 or 5GHz.

I would like to specify that on 2.4 GHz, it is worth using a higher channel number (above channel 8) on your router and also check for contention on your wireless channels from neighbours using ‘netstumbler (PC)’ or ‘istumbler (mac)’ to make sure you choose a channel that is not congested.

2.4 GHz travels through walls better than 5GHz, so is useful if there’s something between your router and your speakers, but it is also more adversely affected by traffic from your neighbours, so if you can find a relatively un-congested channel, you’ll be in with half a chance.

Use a higher channel on the 2.4 GHz bandwidth if you can because it has slightly larger ‘space’ between channels once you take the channel bandwidth into account.

1 Like

Thank you for your suggestions. I will make the the changes to the settings you recommended and see if it makes a difference. Since my original post I am starting to experience the same problems with 96/24 hi res streaming that were originally streaming just fine.

Plus 1 to the list of affected customer.

I am a new Roon user and also a new KEF LS50W owner. I am disappointed to say that I also suffer from the same problem. Any music files that have the sample rate higher than 96 kHz will not play.

The speakers are on the latest firmware p6.3001902220.105039422. Connected through 5GHz bandwidth wifi.

Plus 2 (or 10). I am new as well, just picked up the Kef’s this holiday weekend and cannot play anything above 96 as well. I have traced it to the Kef’s wifi capabilities (as others have alluded to), not Roon. No issues playing the files via the usb input or through a Node 2i (out RCA) using Roon. It is only streaming via wifi (or ethernet) directly to the Kef’s themselves. I am still trying to troubleshoot. Hoping for a solution that doesn’t involve shipping them back.

I had this same problem. I communicated with KEF support who asked if I was on a 5Ghz or 2.4 Ghz network. I wan’t sure but changed the configuration on my router/access point to make sure that the KEF was always connection to the 5Ghz network. I have not had any problems since I made this adjustment about a week ago.