Kef LS50W - can't play hi-res above 96kHz

Roon Nucleus plus - Version 1.0 (build 174) stable

Hi, on my Roon Nucleus I can’t play hi-res files above 96kHZ on my LS50W such are the following:

Files below 96kHZ play fine such as:

I am connected via ethernet to LinkSys Velop (WHW03v1) with latest firmware.

As a comparison, hi-res files such as 24/192 and DSD64 play fine through Roon to my Oppo blu-ray player or my Riva Festival speaker.

Also, hi-res titles at 48kHz 24 bit, MQA 192 kHz play fine through Roon from my Tidal library.

Please help, as I have about 400 albums I can’t play on the new KEF speakers.



This is Damon again.

I figured out a way to play a 192kHz 24 bit file by doing a 192kHz sample rate Conversion to 96kHz.

Is that the correct approach?

I included a screenshot of the signal path.

I’m able to play 192 via ethernet on my LS50W. It’s been awhile, but do have the latest updates on your speakers?

Hi @Damon_Haley,

This method will effectively be down-sampling all the 192kHz content to 96kHz before sending it to the speaker. It is not necessarily a matter of the “correct” approach, but rather if it works and if you are satisfied with the audio stream quality.

As @Shawn_Costello mentioned, I would take a look to see if your speakers are using the newest firmware using the KEF control app as there have been some updates that may improve your experience. We also have a KEF Troubleshooting Guide which may provide other suggestions.

Do let us know if that helps!

– Noris

When you say you can’t play those files, what happens?

Does Roon display an error message?

Does the song ‘appear’ to play, but no sound?

What are the symptoms?

FYI, I can play PCM 192/24 or my LS50w no problem. DSD files have to be converted to PCM by Roon before playing as the LS50w do not do direct DSD support.

The song plays in Roon but I just hear clipping noises from the Kef when I turn up the volume.

The Roon displays no error message.

I did upgrade firmware to latest:
Current Wi-Fi Firmware: p6.2101809171.105039422

I then restarted the nucleus, but still no luck playing 64/192 song from flac or Tidal from Roon.

I would suspect the router.

When you play to the Riva, what does the signal path say? Is Roon definitely outputting 192/24 to the Riva and the Oppo, or is it down-converting first?

So the Oppo and KEF are both connected by ethernet to Linksys a 5-Port Gigabit Ethernet Switch (SE3005).

I have attached a Signal Path Screenshot of the Oppo playing at 64/192 from Roon

Another strange thing is that the firmware listed in the IOS Kef Control App is:

But, the firmware listed at the IP address of the Kef Speakers is:
Current Wi-Fi Firmware: p6.2101809171.105039422

I’m also using a Cat 6 ethernet chord in all places.

Let me know if there are other troubleshooting steps I could take.


OK, I ran a Cat6 ethernet chord directly from my Linksys Velop to the KefLS50.

I have included a picture of the signal path, which is the default for the Kef device in Roon.

I’m still getting total silence or clipping.


Hmm… that’s got me stumped…

Just out of interest… and it’s probably nothing to do with it, but… are you on the original left-right speaker interconnect?

I just tried my LS50W speakers with FLAC 24/192 content and it works as Lossless and fully plays 24/192 with no issues. I do not see the Volume Leveling in my stream as you see in your stream shot. I wonder if you shut off all the extraneous stuff and just try and play 24/192 in a vanilla configuration if that wouldn’t solve your issue.

Hi @John_Aiello , I use Volume Levelling and DSP and up-conversion all the time with my LS50W and it works flawlessly, so I doubt that is the problem. Worth a try maybe.

@Damon_Haley. I’ve just had a good mess about with my setup. I use my Kefs wirelessly as they’re close to the router, so I just tried plugging in an ethernet cable, the Kefs prioritise Ethernet and switched over to it automatically when I plugged the cable in, and went back to wireless (This took a few seconds) when I unplugged the cable.

I’m just wondering whether your Kefs are still connected wirelessly even though there’s a cable in? (This might happen if the cable is dodgy and might cause problems when streaming high-bandwidth content if your wireless signal was weak).

Here’s what I would check…

  1. Do you see the Orange light and rapidly flashing Green light either side of the ethernet plug on the back of the Kef master speaker?

  2. Can you interrogate your Router to see if your Kefs are connected via Ethernet, rather than wirelessly? (Usual login for the Router is, then enter password). You can find the Mac address of your speakers in the Kef Control App under “Speaker Info”, then look at connected devices on the Router to see how that Mac Address is connected.

  3. Another way to check if it’s connected wired or wireless is to log into the speakers at their ip address and the page should mention ‘signal strength’ if connected wirelessly and not mention it if connected wired.

Just thoughts @Damon_Haley. Worth a try…

1 Like

Yeah… mine are differently listed as well…

In the App the firmware is listed as p6.2001806071.105039

Can’t you just move the speakers near the router now to check? Why wait for the 30’ cable?

OK, got the long cable to plug directly into Gibabit switch, which is plugged directly into router. Can’t plug directly into router (Linksys Velop) as it only has one ethernet port and I need a way for Roon Nucleus to be connected by ethernet.

Unfortunately, I still get clipping with music unlistenable on the Kefs. The same source plays fine on my Oppo also connected on ethernet to same network switch.

I verified that I’m on ethernet by going to IP address of KEF where wif-fi settings are not

configured. In addition, ethernet port light is green and flashes rapidly when music is sent to it.

I set all DSP and Audio Device settings to default.

Tonight I tried with two 24/192 sources (flac file and Tidal source). See screenshots.

Are there any troubleshooting steps I’ve missed? At this point I’m thinking that there is a hardware issue on my new KEFs.

Hi, I also restarted Linksys Velop router as I noticed stale devices in device list and verified that both Roon Nucleus and Kef are on 192.168.1.* subnet. Both wifi and ethernet share that subnet with Velop.

The Velop also has a device prioritization feature (for up to three devices) and I put the Kef and Roon ethernet IPs in that list solely.

I then restarted the Roon server and unplugged the Kefs for 1 minute and powered back on.

Still no luck. I think with the better ethernet chord I maybe hear the 24/192 songs slightly clearer but it’s still massively clippy.

Speaking of clippy, I also reset the key speakers to factory defaults with paperclip.

It’s hard to determine if this is a Roon driver problem or KEF, but I’d guess it’s maybe an issue in the KEF processing path.

Let me know what you guys think.

Hi @Damon_Haley,

Can I please ask you to reproduce this issue and let me know the exact local time + date when it next occurs? E.g. 9:23PM on 5/24/19?

I would like to take a look at the diagnostics from your Core when this behavior is occurring to see if perhaps there are any signs towards the clipping behavior you are experiencing.

Also, have you by any chance reached out to KEF regarding this issue yet? Maybe there is something regarding your network that needs modification to play nicely with Roon + the LS50s.

Just in case this helps, we have documented a few router modifications in our Networking Best Practices Guide, while Velop is not explicitly on this list it might provide some further suggestions.

– Noris

Hi @support, yes I reached out to KEF and they had me do a bit more troubleshooting.

Basically to rule out issues with Roon, I set up a Plex Music Server on my NAS and tried to stream the same Miles Davis 24/192 album that had warbled in and out from the Roon.

The good news (for the Roon anyway) is that the Plex also couldn’t play the 24/192 file without clipping in and out.

So this means the problems is not with my Roon Nucleus or its settings.

I reproduced the the issue with the non-audible file again this evening with the KEFs, Roon and my Qnap NAS hard-wired directly to a Netgear NightHawk AX4 router.

Here is the timestamp:

8:38 - 8:40 p.m. MST. on Monday, June 3

At this point I am 90 percent sure that the problem lies with streaming unit within the KEF LS50W.

Please let me know if anyone else has any ideas or if they’ve seen issues with the streaming functionality on the KEFs with hi-res over ethernet.

Otherwise, I’ll be boxing them up and sending back before Friday for a replacement pair.



Hi @Damon_Haley,

Sorry for the delay in getting back to you here. If the KEFs are not working properly with Plex, this further indicates that the issue is either the KEFs themselves, something about the network it’s on, or something regarding the media the albums are on.

Getting a replacement pair will allow us to eliminate one of these variables, similarly you can also try using a different storage location (USB Flash Stick on the Nucleus) to eliminate another. Knowing if the setup works on a different network would be the third test.

Either way, let us know how it goes and if the replacement pair or further tests resolve the issue.

– Noris

Were you ever able to resolve the issue? Was it on the Kef side? I’m running into the same issue and after switching out every other component and cable in my setup, I’m stumped.