24/192 Files Stream Without Audio To HifiBerry Digi+ Pro, RopieeeXL

I have downloaded and set up HifiBerryOS and ordered a new TOSLINK & Digital Coax cable and plan to test this when it arrives. I could only get 24/96 on both my current devices though I think they both support 24/192

Mike

Just tested with a new TOSLINK cable (admittedly also an inexpensive one) and no luck, same limit at 96. And I also thought the KEFs supported coax but I was incorrect, TOSLINK only, so that option is out.

But I was able to test something else: In another room I’m running another HifiBerry HAT but a DAC+, both are running the same RP4’s and both with 2GB RAM, and that roon end point has no problem with 192 content. So given that they’re both HifiBerry devices, both the “+” models, and both running on the same RP boards, I have to assume that this is a cable issue.

So until I’m comfortable paying more than $15 for a 1’ cable, I’m going to have to be content with downsampling to 96. Looking forward to seeing how others go in their testing, though.

Thanks for all the suggestions and help!

1 Like

I have been testing the Dac+ (Analogue output) this last week at 24/192 into my Sonos amp and it’s been working fine for me. It Occasionally stops working when we were doing quick switch listening tests between Sonos output and Dac+ but never when listening to music. General consensus is that the Dac+ sounds better than streamed to Sonos from the multiple family members who took part (but it’s not a huge difference)

I built the Digi+ pro streamer this morning as well, so I will test that later today with the coaxial and Toslink as well as usb into my Fiio k5 pro Dac amp and let you know the results.

Mike

So I have set everything up and using RopieeeXL and happy to say it is playing 24/192 from both Toslink and SPDIF, though I am sure only SPDIF worked a couple of weeks ago. Though that might have been the Onkyo amp to be fair.

Here are some signal paths to my Fiio K5 pro using both 16/44.1 and 24/96 track’s.

Mike

1 Like

This is great, thanks for testing and confirming. Two follow-up questions:

  • What cable are you using for TOSLINK?
  • Are you upsampling just to test 192, or is there another reason/benefit?

I am just using some basic Toslink and SPDIF cables that I went and picked up from a storage box (several years old) and I normally use usb (planning to transition to SPDIF as I get all cables). While it works with Fiio K5 pro, it didn’t work with my Onkyo amp (but that may be limited to 48khz)

I have read that many people say that they get 24/192 with Amazon basic cable’s so could be worth a try as they are fairly cheap.

If you look at the photos I show the path, normally I use max (power of 2) so for a CD rip to flac file I get 24/176
There is a slight improvement in sound quality using upscaling, but it is not a huge or remarkable improvement , when listening on headphone I often prefer DSD256 as this feels slightly better again.

Mike

My Onkyo RZ 740 is limited to 96 optical and coax to my surprise. Optical would fail occasionally at 96. Any higher frequency total silence. Found that limitation somewhere hidden in the manual.
Changed the setup and use an Elac Discovery music server to feed a power amp directly.

Klaus sorry mine did max out at 96 not 48.
As you said, totally silent after that

Mike

Same here on cables, using inexpensive ones, so the only thing left in the equation that could be causing the issue is the KEFs. That’s a bit frustrating b/c the manual says they support up to 192/24 and will downsample/upsample accordingly between the speakers themselves. Since I’m currently running them wirelessly I know that downsampling from 96/24 and upsampling is working fine, so something just isn’t working on receiving 192. Probably worth reaching out to their support to ask about, I’ll add it to the list.

That’s a pain, the only thing I can suggest is trying an Amazon basics cable just to see if it helps.

Mike

I learned 2 things setting up my system. Same Digi+ Pro…

  1. Even though my Denon receiver says it has Burr Brown 192kHz DACs… it doesn’t seem the rest of the hardware supports 192kHz so I’m limited to 96kHz on that device. Had this issue with both coaxial and toslink.

  2. On my other Marantz receiver, same device sends 192kHz over coaxial just fine but toslink couldn’t get past 96kHz. I purchased a better Audioquest Pearl toslink and then 192kHz worked fine. https://www.amazon.com/gp/product/B000F1X6AK

You want a quality cable… either this one or one that’s glass and not plastic fibers.

1 Like

I’d endorse this, you need a decent quality cable but not at prices rivalling equipment. The only proviso I’d add is I’d not loose much sleep over the difference between 192 and 96 material, or 96 vs 48/44 for that matter. Rendered well 44.1 can sound very good indeed and theoretically there’s no reason it shouldn’t.

1 Like

LSX are Roon tested. Did you try to “roon” them directly?
Almost the same issue with LS50 Wireless. The only solution for me with LS50 - downsample to 24/96.
I also have Digi Pro+ (HiFiBerryOS), use it with Hegel H390 (until H390 becomes Roon ready) and it works perfect:



I should try to test Digi Pro+ with KEFs :thinking:

1 Like

Yep, streaming directly to the KEFs as a Roon Tested endpoint works fine for 192. I can’t use it in my setup most days b/c I group various rooms and using the KEFs directly doesn’t allow me to group, unfortunately.

I’ll keep trying cables over the next few months as things move along, and no issue with letting Roon down-convert beyond it just bugging me that I don’t know why. :slight_smile:

Just as a report: connected my LS50W with Digi Pro+ via TosLink and 24/192 stream from Qobuz sounds without any issues:

Ok, have a bit of an update on this. I found the following discussion in the HifiBerry community:

Coincidentally, I just updated my HifiB’s to the latest OS today, 20210203, and it definitely did something. Now when I play 192 content, with Roon re-set to max of 192, I hear a loud pop when the track starts and then I hear a constant chug-chug-chug (think train sound) while it tries to play the 192 track. Switching back to <192 content works fine, and setting Roon to a max 96 and it correctly plays the downsamples 192 content. So to me this means it’s def not a cable issue, it’s something to do with the Digi+ Pro.

I don’t see any notes in this latest OS version on the HifiB git repo, and unfortunately I’m currently not able to log into their community to post my findings, but wanted to share an update here.

Still odd…even odder that it’s working for some on this thread with what looks like the same audio path and same devices. The mystery continues…

Instead of trying to get your DSP speaker to play 192kHz with internal downsampling, which does not work for your setup anyway, you should limit Roon to 96kHz.

In spite of the similarity of the symptom, I do not believe the cause in your setup is the same as in the linked thread. DAC and DSP speakers are entirely different things.

Not sure what you mean by DSP speakers?

I do limit Roon to 96 and life is good, I’m just spending time on this to figure it out, just a curiosity. Life is fine with 96. :slight_smile:

You’re using a speaker that has internal DSP.

This is normal. Most speakers that accept digital inputs have internal DSP. (This is different from traditional active speakers that have analog inputs only.)

Ah, I see, thanks for the clarification. And you bring up a good point: I am using DSP settings in the KEFs, so it will be worth testing disabling all of those to see if it makes a difference.