KEF LSX 5.1 update fixes streaming

I have never been able to get either of my two pairs of LSXs to stream reliably using KEF streaming protocol in Roon. I always had to revert to Airplay for consistent connection but this sacrifices SQ a bit.

Now KEF has released firmware 5.1 which includes a WiFi firmware update and allows for reliable lossless streaming from Roon using the KEF streaming protocol. Update worked flawlessly using the Control app and now Roon and the LSXs are happy together finally. Very pleased with this update from KEF.

1 Like

Update: Redbook 44.1 / 16 bit plays flawlessly and so far 88.2 and 96 kHz have not had isssues. 192 is a no go…cuts out constantly. No big deal but maybe they will be able to get that working or Ilfor now I’ll downsample as needed.

I’m streaming 24/192 tracks via KEF Streaming without a problem - just bought the LSXs and set them up today so this firmware update was a very welcome development.

Good to know it’s working for you. Not sure why mine is not working at 192…I would have thought WiFi issues, but I have one pair hooked into Ethernet network and has the same issues. Curious.

Mine are via Ethernet, too, so it’s weird that’s not working for you.

Christopher: thanks for the heads up. With the firmware update, Roon is now working flawlessly with my LSXs.

1 Like

Same issue, so I did to the wifi settings as it says in the LSX Manual, switched the channel and assigned a fixed ip to the speakers. Now it works wonderfully over wifi (macbook and LSX on a fritzbox router and both in the 5ghz network). 5ghz is essential if you want to stream 192khz. I still notice that it can be unreliable if there is a lot of network traffic in the same network. But for me it works 99% of the time now - before that I had issues with my LSX daily. Hope the update makes it even better!