KEF LSX Enhanced signal path...?

I use Qobuz. Roon Core is on my M1 14" MBP.

I have no DSP enabled. Also have made sure MQA is turned off for the LSX device settings.

So why does it still use volume leveling?

AFAIK I still get lossless audio. I am just confused as to why a “volume leveling” which I have not set up is considered “enhanced”. :slight_smile:

Click the loudspeaker icon bottom right to open zone settings, then click the cog wheel in the pop up and you’ll see if volume leveling is turned on, which I’d bet it is…

1 Like

Aaaaaah. THANK YOU!

Now I need to figure out which wine-heavy evening I chose to set a volume leveling of -5dB… :smiley:


That also got rid of that strange bit conversion from 16 bit to 64 bit to 24 bit.


… maybe your spouse played with the settings …

1 Like

No, that would have been -50dB at least.

1 Like

It’s not strange. Roon does DSP in 64-bit floating point to avoid degradation due to math errors, so that explains 16->64. Then, the bit rate is reduced to whatever the DAC accepts (and the maximum set on that audio device), so that explains 64->24.

1 Like

That precedes every DSP calculation for higher precision to not introduce audible artifacts.
See here for an example.

EDIT- @Marian, you beat me with your explanation :1st_place_medal:

No worries, the more the better.

1 Like

Thank you both! I live and learn.

Does this mean that it’s better to use the Roon app volume level instead of the KEF remote control? (Asking for a n00b friend)

Don’t know how KEF handles volume…

1 Like

According to @mikeb, using Device Control in Roon, as it sounds like you’re doing now, is no different to using the KEF remote, as both simply pass a volume command to the LSX.