KEF's LS50W not finding home network


I hope somebody can help me with this issue. All suggestions welcome!

After returning from a 7 week trip yesterday I plugged everything back in and discovered that the KEF’s did not respond. I did a factory reset and tried to set the KEF’s back up again via the app on my Android phone (new speaker set up).

It finds the speakers but not my home network - even though my phone/laptop/desktop have no problem detecting it. It finds the networks from my neighbours though!

The things I have done so far to enable the KEF’s:

  1. Rebooted everything (router/KEF’s/mobile phone)
  2. Deleted the app and reinstalled it.

Anything that I am missing here?


Forgot to mention:

I have not got the latest update installed.

Everything was working fine before I went on my trip though.



Problem solved - it was down loading the latest firmware update (which was a WiFi update!).

A mate of mine brought his KEF’s LS50W down to my place and he had the same issue.

We then hard wired the KEF’s and they worked fine!

Decided to do the firm ware update (which I was originally advised against by the guys from the shop I bought them from - great guys though! Very good support otherwise).

After firm ware update they worked fine!

I’m thoroughly enjoying my payment for the help; Dutch liquorice! Yum!