Landscape mode on Google Nexus 7

I use a Nexus 7 tablet. Roon runs mostly on Portrait mode and sometimes starts up in Landscape mode. I’m unable to make it start or change to landscape by demand.

Is there a way to get it start or change to landscape?


I have a Hudl 2 with similar behaviour, only that it acts like a phone display in portrait but in landscape it gives you the full experience. It only comes up in landscape if it asks you to select “full screen” or a phrase similar so the issue is related to how Roon sees the screen size available to it. I don’t know if you can prescribe how Roon behaves on startup but that is where I would look. I use a Pixel C now which only works in landscape! :thinking:

I was able to make it go into landscape mode by following the steps below:

a) Start Roon (in portrait mode)
b) Send Roon to the background by pressing “Home”
c) Putting the tablet to sleep (Roon still running in the background).
d) Waking the Tablet, holding it in landscape mode and then launching Roon from the recent app list. It gives the option of “maximised/fullscreen”. Tapping Fullscreen opens Roon in Landscape mode.

It now stays in Landscape till it is closed and re-launched.
Landscape has many features which are missing in portrait mode for some reason.

portrait = phone mode
landscape = tablet mode

Roon supports a limited interface in phone mode.


This stopped working after the latest app update.
I was able to fix it so that it always opens in landscape (Tablet) mode by lowering the DPI from the default of 323 to 290.
Details on how to change DPI with or without root: