Linksys MR9000v1 and port forwarding for ARC to work

Roon Core Machine

Dell Latitude E7450, Intel Core i7 5600 PCU @ 2.6Ghz, 8.00 GB (7.89 GB usable)

Networking Gear & Setup Details


Connected Audio Devices


Number of Tracks in Library

6513 tracks

Description of Issue

I do not believe I have the technical ability to port forward. I have done all the troubleshooting up this point with no success in getting ARC to work. I need the most basic instructions possible or live help. I appreciate your help.

@Ed_Goettl, I moved your post to the Port Forwarding Support category so the community and Roon staff can provide you better support. Can you provide any additional details on the error you are seeing when trying to get ARC to work?

Please alsoinclude the following information:

  1. Do you have any additional network hardware, like additional routers or managed switches?
  2. Who is your internet service provider and what is your geographic region?
  3. Is your Modem configured in Bridge Mode so that it operates only as a modem?

Hi @Ed_Goettl,

Could you please also provide the message you get why Roon Arc isn’t working? You can find this message via the Roon App. Go to Settings → Roon Arc

Kind regards,


1 Like

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“”},
“status”: MultipleNatFound
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}

  1. A Netgear but that is used by the kids and never for any of my streamers.
  2. I’m in a suburb of Minneapolis and Mediacom is our provider.
  3. I’m sorry that I don’t know.

Really appreciate folks being willing to help me.

Hi @Ed_Goettl,

In the error message i see MultipleNAT found. This can be caused by 2 different things:

  1. Mediacom is using Carrier-Grade NAT
  2. You have multiple modem/routers in your setup.

I did a quick Google search and checked the list of know Carrier Grade-NAT ISP’s created by Roonlabs. I couldn’t find Mediacom in the list. So i think point 2 is the problem at your place.

Could you be so kind and give us a description of the gear which is in the setup and at which router your Roon Core is connected (i hope by cable)?

Hope i made my question clear enough.

Kind regards,


1 Like

Thanks. We have the aforementioned Linksys, which the core is connected to wirelessly, a Linksys RE6300 extender (shows as different network) and a Netgear R7000.

I believe this is one of the issues and why you are seeing two different networks in the ARC error message. It appears you may have three separate networks running in your home.

What device does Mediacom provide to you to which you connect your MR9000 router?

Technicolor CGA4334.

Sorry 4234

The 4234 is a gateway/router, so from my understanding you have 4 routers possibly all working independently of each other:

The 4234
The MR9000
The RE6300
The R7000

Can you povide any more details on how these are configured and what connects to what and if the connection is via WiFi or Ethernet cable?

The 4234 - input cable from provider. Out cable to each router. Just added out cable to core hoping that would help, but it didn’t. Output cable to phone.
The MR9000 - input cable from modem. Output cable to Node 2i.
The RE6300 - it just plugs into a wall outlet to extend coverage to upstairs rooms. Rarely used. Shows as different Wi-Fi network.
The R7000 - input cable from modem. No out cables.

Hey @Ed_Goettl,

Thank you for your patience while we’ve diligently worked to reach every request for support with port forwarding. The diagnostics you’ve provided suggest there is a redundant layer of network address translation preventing port forwarding.

This can either be at the local-network level (commonly as a result of two routers), or at the level of your service provider (in the form of carrier-grade NAT).

If your setup involves an ISP-provided gateway (modem/router combination) and your own third-party router:

  • In the web administration interface of the ISP-provided gateway (modem/router combination), enable Bridge Mode or equivalent, where the ISP-provided gateway does not have DHCP routing enabled.

  • Alternatively, if you have already created a manual port forwarding rule in your 3rd party router, you can add an additional rule to forward the port through the ISP/second router.

If you only have one router in your setup or your modem is already in Bridge mode, please take a look through our list of known router and internet service provider solutions, as other users may have already encountered the same situation: ISPs and Routers: List of Known Solutions and Workarounds

You can reach out directly to your service provider to ask if they support port forwarding; this question will often enough to prompt them to explain whether or not the carrier-grade NAT they’ve implemented can function with ARC.

More specifically, you can pass along the following questions:

  • Have you implemented carrier-grade NAT for my account level?
  • Have you fully implemented IPv6, or do you have IPv4 addresses available?
  • Can I request a static IPv4 address to support port forwarding?
  • Are there any ports you have reserved at the ISP level I should be aware of?
1 Like

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.