Linn klimax ds showing up as airplay [Solved by updating the remote]

I updated roon and enrolled in linn klimax ds beta and updated my linn device. However, i am seeing my linn device show up as airplay only in the network section. Is this expected?

No, it should be showing up in a “Linn” section.

Take a look at this setting–maybe it picked the wrong network by default:

Also, make sure both your Roon Core + Remote are running Roon 1.5 (Build 320) or higher.

1 Like

Perfect. My iPad remote was 1.4 roon version and I didn’t see these options… I tried on my Android phone (my son has my iPad now) which is running remote version 1.5 and I see this option now! Works great thank you!

Ich habe eine Ăśberraschung erlebt Roon versteht Linn unter Zonen, Klimax DSM

I have the same problem with my Majik DS. It appears in the Airplay Zone. Both my core and my iPad run under Roon 1.5 built 320. The subnet for Linn streaming is I can change it for 10,252.203.12, this is my only other solution but My Linn device still appears in the Airplay zone.