Linn streamers inaccessible with 2.0.3 and RoonOnNAS for QNAP

See this thread: LINN DSM Devices only showing up as AirPlay with ROON Core 2.0

Looks like multiple people using RoonOnNas with Linn devices have lost access to their streamers with the 2.0.3 update.

Is there a way to downgrade from 2.0.3 to 2.0?

From the log, this looks like the error causing the problem?

11/09 09:13:26 Error: [transport] Unable to initialize SongcastDirect, exception: System.DllNotFoundException: Unable to load shared library 'ohNet' or one of its dependencies. In order to help diagnose loading problems, consider setting the LD_DEBUG environment variable: libohNet: cannot open shared object file: No such file or directory
   at OpenHome.Net.Core.InitParams.OhNetInitParamsCreate()
   at OpenHome.Net.Core.InitParams..ctor()
   at Sooloos.Broker.Transport.SongcastDirect..ctor(State state, Module module)
   at Sooloos.Broker.Transport.Module.Enable()

No Roon never offer Rollback, 1.8 legacy being the exception

libohNet is sitting in the Appliance directory as it should be…

This is as far as my technical abilities go…

I have same error in log. Roon server running one QNap NAS

This is to confirm the problem of visibility of Linn DSM as AirPlay only. Roon 2.0 build 1148 on QNAP TS 253B NAS.

I have updated my Mac, Ipad and Iphone with the latest apps and downloads but I can’t still se my Linn without use the airplay suggestion …

But now it works :slight_smile: