Linux Roon Control GUI Please [not on roadmap, you may try to use Wine]

Linux, and the difference between turnkey people and network hobbyists.

The fact that Rock is based on Linux is coincidental and most people don’t care because the main point of Rock is that you never are in direct contact with the OS. As long as it just works, it could run on Win (if we ignore the licensing issue), FreeBSD, or Hurd. Installing Rock on a NUC can be done by all but the most computer-challenged people.

This is very different from needing the Roon remote to work on Linux because one’s main desktop/laptop runs Linux, which is a minority thing, even though you do and I have also done for 3 decades.

Linux as minority GUI is starting to end.
M$ is switching more and more to Linux subsystem to offer its products as services Windows GUI as a Service Office as a Service etc.

Steam Deck uses Linux and users are happy with it.

it is time to add roon remote support for Linux!

2 Likes

Steam has it’s own variant of Wine called Proton. Most of the games offered by Steam under Linux use Proton to run the Windows version. So just try and do the same for Roon on Linux (already mentioned in the title of this thread).

1 Like

i know - and its a good workaround.
A workaround is still no solution.

A native roon-remote would be a solution :wink:

A solution for what? Maybe Roon Labs will offer a “native” Linux GUI when most game studios start offering their games as “native” Linux version too? Maybe sooner, maybe later?
Just add your vote on top, that probably helps most.

From a post by Brian Luczkiewicz:

The user interface is driven by a piece of technology that could be best described as a game engine. It supports fluid animations, and we are trying to keep the frame rate at 60 frames per second (fps), just like a game.

I would be surprised if more than .03% of all Roon users even knows what Steam or a Steam Deck is. :neutral_face:

1 Like

It would be nice at least to explain why is it necessary to have so big load when running in Wine. When we see no benefit at all. And we know it wasnt there before.
That means it could not be hard to implement some switch to disable this. Whatever it is.

might be - but as said it was just an example for a community with dedicated users. Since especially gamer where always mentioned in context of Windowsexclusivity.

An obviously it wasn’t so bad since the windows conversion rate on the deck is slim. Hence my theory a native RoonGUI wouldn’t be just a “waste of resources” :wink:

Evidence?

I am seeing something very different than you are. They “switched” nothing and have moved zero UI to Linux.

The yet-to-be-rrlased Steam Deck is not a Linux Desktop OS. It is a specialized OS (SteamOS) built on a Linux kernel and runs its own custom apps and Wine for game selection and gameplay. It is about as far as you can get from Linux UI.

We also go down the Steam Deck route: Use Wine.

A native Linux/x11 version would be better, but it’s not on the roadmap.

Which, as you know, was fine until that 120 Hz CPU issue started for quite a few people …

Just implement something in future that will revert to pre-903 build behaviour. Some switch/option to turn off this “secret thing” that does nothing but extreme load. Pleeeease. Roon is not free software. We linux users can have wishes too.

We know already that windows remote DOES run fine in wine. It was perfectly usable before 903. You didn’t have to develop a linux version.

Since 903 I havent observed anything new in UI. Still booklet images did not become 4K video. But my core i5 cpu works like playing 8K with software decoding. Why?

We made some changes to support >60hz displays. The change uses platform specific APIs to wait for the monitor refresh period.

In this case, we use this API:

Is it possible that your Wine version, or the Mesa version, or the driver’s it sits on are not supporting this call properly? I ask because this does not affect many using Roon on Wine.

I know, you suggested the 120 Hz refresh change as a possible reason in the build where it started. And you changed the thread title of this thread from “use Wine” to “you may try to use Wine”, which is why I felt compelled to reply when you now wrote “use Wine” :wink:

I don’t know what would be special about my setup. It’s certainly possible to likely that there is an issue somwhere in the stack from graphics drivers to composer. However, I have the same under Wayland and Xorg, and I am using a standard current Ubuntu on a reasonably current Dell XPS with gen8 i7 Intel graphics (4K). (The same with the internal secondary AMD graphics).

There are many other people in the relevant thread with many different distributions and hardware, including apparently spockfish himself (who wrote the linux install script) at least for a while (I don’t know how it developed) and frequent contributor Martin_Webster, though he is not bothered too much because his fans don’t start because of it.

I believe fan noise is a common factor in how annoying it is perceived. Some people in the thread initially thought they were not affected, until they checked their cpu monitor. I could also kind of live with a fully loaded core if my fans were silent (but I just had the laptop cleaned and repasted and they still blow). How do you know that it does not affect many, telemetry?

2 Likes

SteamOS is not a custom kernel is just GNU/Linux as every other and afaik its not its own OS it is a preconfigured/customized ArchLinux. (same what i use just that its called Manjaro)

It’s arch with KDE, it even uses stock KDE menu layout when switched to desktop mode

I just installed the latest version of Linux Mint and then installed the Roon control via this method which I have used before to great effect. When I install it all works and I can use Roon no problem, however when I reboot Roon won’t restart.

Has anyone any ideas on how to remedy? Thanks.

It’s a perpetual sh!t-show, I stopped wasting my time with it.

How do you start it? Did you check if the command line is correct in the launch script and, if you use the launcher button, if it’s also correct in the launcher (the *.desktop file)?

Thanks for the reply @Suedkiez. I think it was wine related, I updated to 7.14 and it seems to be working now.

1 Like