Linux Roon server not playing high res files to Squeezebox [Fixed in 1.3]

Again, what Harry said. That has been my procedure each time I’ve switched over servers or made any change at all on the SBT.

Once again, the character of the noise should help point us in the right direction. I’ve heard noise like this from digital audio before. I just can’t place it. Somebody who has been around the Squeezebox system should be able to tell us what it’s a symptom of. I have tried googling to see if I could find anything in their forums, but the only keywords I can think of are too broad. When I narrow them, I end up back at tis thread. But somebody’s got to know.

And again, what distro and version of Linux did you use for your test? If one of us could replicate your successful implementation, that could help identify and fix the point of failure in our setups.


Hey @Carl_Seibert @spockfish – we discussed this today, and I appreciate your patience as we work to understand why your experience is different from what we’re seeing (or what we’ve heard from others).

We are doing some additional testing, and have another meeting planned for tomorrow to discuss this further. We’ll come back to you with some additional questions in the next 24 hours.

For now, I can tell you that our testing was done on Ubuntu 16.04 – if you guys are interested in testing the affected boxes with a different distribution (with a VM, or the Windows install, or whatever you feel up to testing), it might be useful.

I would also be interested to know if, when playing 24/192 to the Touch, you get the purple “lossless” light in Signal Path.

Again, thanks for your patience guys – looking forward to resolving this for you soon.

To those having issues: @Carl_Seibert @spockfish … I’m about to test this using a SBT with Roon Server running on Arch Linux to see if I can replicate the issue. Before I do this, are you using the Touch as transport or as a DAC?

As transport.

Well, 3 24/192 albums in and no issues using SBT USB out to DAC.

Perhaps the answer lies in the version of ALSA you’re using? Is your Fedora up to date?

Not using Fedora. Running OpenSUSE Tumbleweed, which is a rolling release with up-to-date packages.

Bizar this. Both you and the dev’s don’t have any issues at all, while @Carl_Seibert and I are facing the same symptoms.

Just to rule out any kind of distro issue I’ll do a test with ArchLinux myself this weekend.

1 Like
Advanced Linux Sound Architecture Driver Version k4.7.6-1-ARCH

ffmpeg version 3.1.4 Copyright (c) 2000-2016 the FFmpeg developers built with gcc 6.2.1 (GCC) 20160830 configuration: --prefix=/usr --disable-debug --disable-static --disable-stripping --enable-avisynth --enable-avresample --enable-fontconfig --enable-gmp --enable-gnutls --enable-gpl --enable-ladspa --enable-libass --enable-libbluray --enable-libfreetype --enable-libfribidi --enable-libgsm --enable-libiec61883 --enable-libmodplug --enable-libmp3lame --enable-libopencore_amrnb --enable-libopencore_amrwb --enable-libopenjpeg --enable-libopus --enable-libpulse --enable-libschroedinger --enable-libsoxr --enable-libspeex --enable-libssh --enable-libtheora --enable-libv4l2 --enable-libvidstab --enable-libvorbis --enable-libvpx --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxvid --enable-netcdf --enable-shared --enable-version3 --enable-x11grab

If you’re going to be doing some additional testing this weekend @spockfish:

I’d be interested to know whether this test works from the MBP running the Roon Core, as opposed to using LMS.

One more question @evand and devs: @evand stated he played over USB. And the dev team?

Cause I played it over coax (as my DAC does not support high res over USB).

I’ll plug coax in tomorrow and play again. I’ve moved to my listening room for the evening… Next time I get up it’s to go to bed.

Ok that was a quick test.

Running Roon Core on MBP works. Just like LMS. Over wi-fi.
So it is related to my Linux server. Hmmm.

Interesting. I will check what was used in our test.

@Carl_Seibert – any chance you’re using coax? Can you give us the details of your DAC/setup after the SBT?

@spockfish – can you give any relevant details too, like what DAC you’re using?

Thanks guys

Yeah I’m using a Rega DAC.

@mike have you seen that my test running it from MBP works actually?

Do you have volume control on the SBT set to fixed or are you using digital attenuation?

@Mike - Yes, the signal path shows lossless.

@evand - I’m running Fedora 22, which by definition is far from up to date, although according to the Linux thread on this forum “it has been reported to work”.

I’m using coax from the Squeezebox (used just as an endpoint/bridge) to my Neko D-100 MKII DAC. (In my other rig, the DAC is a PS Audio NuWave. Same behavior DAC-wise in both setups.)

According to the utility that ships with RoonServer, all dependancies are met on my Fedora box. Does ALSA matter, given that I’m not using Roon Bridge on the Linux machine? But, in any case, ALSA does work on that machine. I do run a desktop on it and I can play HIRes files in the native Linux players.

I think I may have an Ubuntu 16.04 image around here somewhere. Over the weekend, I’ll give that or Arch a try in a VM and let you now what happens.

And, like Henry, RoonCore on my Mac laptop works fine.

@evand – Good question. I’m using the digital volume in Roon. I believe the volume on the SBT is set to variable, but set at 100%. I’ll check.

It seems to me coax is the common denominator, will try to replicate in morning.

OK. I now have build 161, downloaded today by the installer script, running on a Kubuntu 16.04.1 instance in an Oracle VirtualBox on my Fedora machine. The network situation is as above with a couple of trips through VirtualBox’s virtual bridge router added to the mix.

As I write this, a 96K file has been playing for about 30 minutes through the SBT.

What I have noticed so far:

The Squeezebox was very temperamental. It took several power cycles to get it to behave. It fell off the server once or twice and for a while, it would appear to play, but no sound was produced and the progress bar on the histogram wouldn’t move. What’s more, it would pretend to play each track for only a few seconds and then advance to the next track. Very odd. After one more power cycle and selection of the library on the SBT and the SBT on Roon, it came to the condition it’s in now. Whether that’s going to be stable is anybody’s guess.

The ancillary symptoms have changed. The queue now shows tracks when I play an album, and the Limit Bit Rate dialog now shows 96K as an option, as it should.

A 192K file seemed to play OK, but it was struck with pauses that were pretty obviously network related. I’ll go back to playing a 192K file, not to listen to, but just to see if it eventually fails to noise. I suspect it won’t, but we’ll see.

The signal path dialog looks different to me. There’s a big Logitech logo that I don’t remember from before and the last link says “Squeezebox streaming”. I don’t remember that terminology from before either. but I don’t have a screenshot of that dialog from before, sadly. I’ll upload a screenshot.

So it looks like now we need to figure out what’s different between Ubuntu/Kubuntu and my Fedora and Harry’s Suse setups.

More as it develops.

Update: It played through an entire album at 192K, pausing every so often to re-buffer. It then played Radio for an hour or so. Then I played a song on Tidal. Pretty safe to say that it’s working.

Now if we can just figure out what different component in Fedora and Suse is the bugbear and fix it…