Linux Server / Airplay

Any thoughts or suggestions appreciated in helping resolve issue.

Problem: Linux Server & Airplay

  1. Select zone (HomePod via Airplay)
  2. Select music
  3. Hit play
  4. Music time counter never starts and no music is heard.


  1. If zone selected is Roon Ready device, playback is OK.
  2. Single zone. Haven’t even tried Grouping yet. Mentioned because post seen regarding issues showing up for Grouping Zones on Linux.

Fresh install of Roon Server 2.0 (build 1353) production
Ubuntu Server 22.04 LTS
Intel 13th Generation Core i7 (13700H)
NVME system drive
20TB USB Ext4 music storage
Roon Server Easy Installer used
libicu66 installed
(Computer dedicated to Roon Server)

OS is Ubuntu Server 22.04.3 LTS

How is your Server connected to your network? Is it possible to see how your HomePod is connected via WiFi, specfically what band (2.4 GHz or 5 GHz)? If it’s the 2.4 GHz band you may not have enough bandwidth to support a Roon stream and may need to connect it to the 5 GHz band.

Hi Robert. Thank you for your response. The HomePods are all connected to the 5ghz radio (logged into WiFi router to confirm). The Roon Server itself is plugged into the WiFi Router via Ethernet.
As a side note, I am switching over to Ubuntu from an older Intel Mac mini, everything else is identical. Never had any airplay issues when Roon Server was running on the Mac.

Another side note: I can play on all speakers in home just fine through Roon Arc (iPhone) and selecting speaker to playback on.

AND as yet another side note:
The Roon Ready device that plays fine can also be connected via Airplay, but when connected via Airplay, it exhibits the same behavior as the Apple HomePods. (music doesn’t play and music progress indicator/ timeline stays at 00:00. Play button shows active and the audio meters icon is bouncing like it should be playing, but alas, nothing is heard and audio timeline doesn’t progress)

I have a similar Roon server setup to yours (Ubuntu Server 22.04.3 LTS etc). I just tested AirPlay to one of my endpoints, a Linn Kiko, and it worked fine. However, it does not work to one of my Apple devices (a Macbook), same symptoms as you describe. I’d suggest you enter this as a new Roon support request, as it looks like a bug somewhere between Roon and Apple.

OKAY, progress here. It appears to be firewall related.

(In my troubleshooting, I brought in a Sonos speaker. Weird behavior there too. Music would consistently stop at :29sec and go to the next song, or stop at :29sec and state an error that it lost control of audio device.)

Then I randomly had a thought to make the firewall Wide Open to ALL devices for ALL port on my local LAN on the Linux Roon Service, VIOLA! both the Airplay and Sonos starting playing back perfectly.

I have been looking for a definitive list for what ports I need to have open for Airplay & Sonos as I’d rather not have EVERYTHING Wide Open.


Thank you!

Okay, which ports to open seem to be an ongoing frustration for lots of folks in the Roon Community Discussions. I’ll go ahead and assume this will be the end of my discussion now and will not be answered anytime soon. I am really enjoying Roon, but nothings perfect.

@Brandt_Kuykendall, this thread is in the Roon Linux discussion category. Roon Support does not monitor these categories typically as they are focused on the Support categories.

Other users may be able to provide ideas. You may want to consider renaming your post or creating a new one specific to the AirPlay/firewall port question you have above, possibly in the Roon Networkking category.