Linux server unreachable after a couple days using Roon

Hello,

I have issues with my Roon server on linux Ubuntu server (headless).
The server runs flawlessly until I mount the music folder from a Synology nas. After mounting the shares, the Roon server runs fine for a day or two, then the linux server becomes unreachable. I cannot connect to it through ssh anymore and if I connect the server to a screen and keyboard the screen is just black.

Can you help me out what could be the issue? My feeling is that maybe I do not use the right mount command in the /etc/fstab.

This is the command line I use:

//192.168.1.2/music /home/tark/music cifs username=tark,password=***,vers=2.0,rw,uid=1000,gid=500

(I used *** to hide user and password)

Not sure, but it could be power management causing Ubuntu to sleep (I’ve not had this happen to myself though).

Try the below to turn off (mask) power management.

sudo systemctl mask sleep.target suspend.target hibernate.target hybrid-sleep.target

Then

/etc/pm/sleep.d#

Then this to see if sleep is dead

systemctl status sleep.target

You should get the below
● sleep.target
Loaded: masked (Reason: Unit sleep.target is masked.)
Active: inactive (dead)

When you have the blank, black screen, have you hit enter on the keyboard several times to see if the terminal screen appears.

Also, are you on the latest Ubuntu Server?

Hi, thank you for following up to this.

Right now I am trying the latest Ubuntu server but previously I was running the 20.04 LTS. Same issue there. I also tried to mount using NFS instead of Samba but I still have the same issue where the ubuntu server becomes unresponsive after a day or two.
When the Ubuntu server goes unresponsive it does not wake up no matter which key on the keyboard I press.

I entered the sequence of commands you suggested and indeed the result is:

○ sleep.target
     Loaded: masked (Reason: Unit sleep.target is masked.)
     Active: inactive (dead)

Thank you, lets hope this was the issue.

I have been running 20.04 LTS without a hickup.
I suspect it is not the distribution that is the problem.

1 Like

In full agreement.

I think Synology related, but can’t explain why Ubuntu Server becomes unresponsive.

Prior installing Roon, the pc I use as server never gave me any issues. So I guess it might be the Nas… Tho it is really strange that a network share kills the whole server…

Did you separately set the NAS as a storage folder in Roon? If you did, that could be the problem, because RoonServer creates a separate mount point for the NAS besides the one you gave in /etc/fstab. Two CIFS mount points for the same target don’t play well together in my experience.

1 Like

I installed linux server, then mounted my music to it.
Then installed roon server and from my ipad i just load a roon backup…

I am trying to remember what I did when I first created my roon backup, I think what i did is… maybe I added the nas location instead of using the linux mount!!

Do you think its best do use the synology mount point or to let roon mount it?

I don’t know that it matters which one, but pick just one :grinning:

I tried both ways (by adding music using the nas address and the address of the mount on the linux server) but the problem persists. At this point I guess its an hardware problem?

In your situation I’d start a thread on the Support forum providing the information requested, so as to get the attention of the Roon support staff. I’ve been running Ubuntu Server headless for my Roon core since I got Roon 6 years ago, for a while all the music was on a Synology NAS, I’ve never experienced that problem.

Thank you for your feedback, I’ll contact Roon